[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#689548: marked as done (debian-installer: serial console glitches)

Your message dated Thu, 4 Oct 2012 16:54:55 -0400
with message-id <20121004205455.GA24750@mycre.ws>
and subject line Re: Bug#689548: debian-installer: serial console glitches
has caused the Debian Bug report #689548,
regarding debian-installer: serial console glitches
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

689548: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=689548
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: debian-installer
Version: 20121003
Severity: normal


i've set up a wheezy box for running virtual machines using libvirt,
QEMU/KVM, virt-install, etc.

i don't really like installing VMs using VGA-over-VNC, so i tried a
serial console installation, like this:

    virt-install \
        --name=mytestvm \
        --ram=1024 \
        --vcpus=1 \
        --cpu host \
        --disk pool=guest_images_lvm,size=32 \
        --network bridge=br0 \
        --graphics none \
        --location http://mirrors.kernel.org/debian/dists/wheezy/main/installer-amd64/ \
        --extra-args="priority=low -- console=ttyS0,115200"

i ran this over ssh, running in an 80x25 xfce4-terminal, value of TERM
was "xterm", if that matters.  some things i noticed:

    * pressing "end" on my keyboard didn't go to the end of a list of
      menu items, but instead acted as if i had selected "go back" (that
      is, as soon as i pressed "end", the previous menu screen was

    * normally on a long menu screen you can scroll down by pressing the
      down arrow key.  this doesn't seem to work, and i couldn't manage
      to reach the (hidden) options on the "configure the package
      manager" screen where you can toggle sources.list entries for the
      security and volatile repositories.  i've attached a screen shot
      of my terminal to show what this looks like.

Robert Edmonds

Attachment: configure_the_package_manager.png
Description: PNG image

Attachment: signature.asc
Description: Digital signature

--- End Message ---
--- Begin Message ---
Samuel Thibault wrote:
> Just run your virtualization tool inside a screen, the screen terminfo
> is quite similar to vt102.

ok, the installer UI works flawlessly in screen.

Robert Edmonds

Attachment: signature.asc
Description: Digital signature

--- End Message ---

Reply to: