[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: di-netboot-assistant update for experimental

On Sun, 2009-10-25 at 06:20 +0100, Frans Pop wrote:
> On Friday 16 October 2009, Frank Lin PIAT wrote:
> > I have finally resolved and merged a bunch of patch I had for
> > di-netboot-assistant.
> > [..]
> I don't think experimental is the right choice here. I doubt you would get 
> anybody to actually test it from experimental.

The new way to handle prefix (was) an experimental.

> If you are happy with it, I think you should just upload to unstable
> and deal with bug reports ASAP when they come in.

Yep, I am ashamed that some of the bugs have been pending for many

> IMO the "::/" prefix that looks to be required now should be documented[..]

Done (I mean, I hope it is clear enough now)

> There is also an upgrade problem. It looks like when I upgrade that the 
> default configs do get changed, but not the actual existing configs 
> in /var/lib/di-netboot-assistant/, nor the generated ones under the 
> tftpboot directory. So after I changed my DHCP server config to drop 
> option 210, nothing works anymore. Please provide clear instructions how 
> to move from an "old" setup to a "new" one.

I have included a migration script. The remaining action are explained
in NEWS.Debian but they should actually be optional.

> I tried making the changes manually, but ended up with a broken setup. Not 
> sure if that means the ::/ prefix does not work for me or if I missed 
> something...

Adding ::/ manually everywhere would be very tedious.
My script should be idempotent, so if you downgrade and re-repgrade, you
should be fine (unless you actually broke a repository, which you can
simply purge/reinstall).

> Could you also fix the fact that the generated 
> debian-installer/pxelinux.cfg/default file gets double newlines between 
> items?

This is fixed for new installed repositories (the transition won't be
really nice).


Reply to: