[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gtk 2.0.x or 2.9+ for etch g-i ? (Was: graphics or text as default)

Eddy Petrişor wrote:
On 5/16/06, Sebastien Bacher <seb128@debian.org> wrote:

Le mardi 16 mai 2006 à 18:42 +0300, Eddy Petrişor a écrit :

> So the questions are:
> - Is it OK for the GTK+GNOME team to have D-I people (and maybe with
> the help of some gtk/gnome people) build some udebs for GTK
> _with_the_DFB_ backend, as it is now for the 2.0.9 version?

Sure, no objection with that


So, if i understand correctly, there should be definitely no problems in moving to more recent GTKDFB libraries, right (no conflicts with GTKX pavkages) ? do we all agree about moving to 2.9.0 (needs minor patches) or CVS snapshot dated 2006-03-26 (previous to 2.9.0 but compiles "out of repo") ?
GTK <= 2.9.0 requires the following libraries

glib-2.0 >= 2.10.1
atk >= 1.0.1
pango >= 1.9.0
cairo >= 1.1.6

We already have correct glib, atk and pango, but we need to repackage a newer cairo compiling it with the DirectFB backend enable against DFB 0.9.24 (the detailed GTKDFB packaging process is described here [1]). Who's going to do this? in the case we can't do this by ourselves, could the debian-gnome team, who nicely offered to help us, support us?



[1] http://www.directfb.org/wiki/index.php/Projects:GTK_on_DirectFB

Reply to: