[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gtk 2.0.x or 2.9+ for etch g-i ? (Was: graphics or text as default)

Le mardi 16 mai 2006 à 11:07 +0200, Sven Luther a écrit :

>   1) you did comment on gtk 2.9+ for etch as the main gtk package, but does
>   this advice also hold in a 2.0.x vs 2.9+ d-i gtk-dfb scenario ?

As written previously upstream changed the ABI number so updating to GTK
2.9 would require updating libgnomeui (and probably some other parts of
GNOME with it) to 2.15, I don't think that's something we want to do for
now no

I don't know how the d-i uses GTK, but does the ABI number change has an
impact on it too?

>   2) do you have any comment and advice concerning re-use of the gtk packaging
>   infrastructure to build the needed .udebs and -dev libraries, in such a way
>   that they would not conflict with the remaining gtk libraries.

Take the GTK source package, rename it, drop the binary packages you are
not interested too, renamed the other ones to no conflict? Then you
probably need to make them conflict with the unstable packages or change
the location of the files and the .pc, etc according to that. Note that
update to GTK 2.9 requires to package pango 1.13 too and a libcairo 1.1
and might have to do similar changes for them too. That's really a non
trivial way, do you really need the new version for etch?

Sebastien Bacher

Reply to: