[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gtk 2.0.x or 2.9+ for etch g-i ? (Was: graphics or text as default)

Eddy Petrişor wrote:
On 5/16/06, Attilio Fiandrotti <fiandro@tiscali.it> wrote:

So, if i understand correctly, there should be definitely no problems in
moving to more recent GTKDFB libraries, right (no conflicts with GTKX
pavkages) ? do we all agree about moving to 2.9.0 (needs minor patches)
or CVS snapshot dated 2006-03-26 (previous to 2.9.0 but compiles "out of
repo") ?
GTK <= 2.9.0 requires the following libraries

I think it does not matter that much to us if it is a snapshot or
2.9.0, but I think that 2.9.0 would help us because we will not be
alone on this ground (others might face different problems with 2.9.0,
but there are less chances of that happening with a cvs snapshot). As
the debian packaging system allows patching before building, I would
opt for 2.9.0.

i'm going to file tomorrow bugs and patches to gnome BTS, so that 2.9.0 can be soon made compile correctly with the DFB backend activated.

glib-2.0 >= 2.10.1
atk >= 1.0.1
pango >= 1.9.0
cairo >= 1.1.6

Do these change for 2.9.0?

The above library requirements apply to both GTK 2.9.0 and 2006-03-26 CVS snapshot (which is older than 2.9.0 ). More recent GTK CVS snapshots require glib 2.11, pango 1.11 ( and DFB 0.9.25 i think).



Reply to: