[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#334598: marked as done (first stage preseed command failed with exit code 127)



Your message dated Tue, 18 Oct 2005 18:17:12 -0700
with message-id <E1ES2Zs-0002rh-00@spohr.debian.org>
and subject line Bug#334598: fixed in preseed 1.10
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 18 Oct 2005 21:18:27 +0000
>From stappers@stappers.nl Tue Oct 18 14:18:27 2005
Return-path: <stappers@stappers.nl>
Received: from gpm.stappers.nl [213.84.119.166] 
	by spohr.debian.org with esmtp (Exim 3.36 1 (Debian))
	id 1ERyqp-0003gf-00; Tue, 18 Oct 2005 14:18:27 -0700
Received: by gpm.stappers.nl (Postfix, from userid 1000)
	id 4B5FF794A0; Tue, 18 Oct 2005 23:08:09 +0200 (CEST)
Date: Tue, 18 Oct 2005 23:08:09 +0200
To: submit@bugs.debian.org
Subject: first stage preseed command failed with exit code 127
Message-ID: <20051018210809.GB8742@gpm.stappers.nl>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="PmA2V3Z32TCmWXqI"
Content-Disposition: inline
User-Agent: Mutt/1.5.6+20040722i
From: stappers@stappers.nl (Geert Stappers)
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Level: 
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02


--PmA2V3Z32TCmWXqI
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

Package: debian-installer
Version: 20051017 & 20051018
Severity: normal

Hi,

Preseeding "preseed/early_command" and "preseed/late_command" doesn't
seem to work....

Checking available examples show only comment lines.
( I have the feeling that preseed/...._commands aren't widely used )

The problem was first encounter in at the end of the first stage.

Syslog nicely reports the the command line as it in the preseed file
( no line wraps or other malformed isssues )

Rerunning 'preseed/late_command' in console VT2 with
 /usr/lib/prebaseconfig.d/05preseed
gives the same error dialog box is the exit code 127

Editting the value of it in /var/lib/cdebconf/questions.dat
and reducing the string to just `wget http://host/path/file`
with another /usr/lib/prebaseconfig.d/05preseed
gives the same error message.

( `wget http://host/path/file` works fine )


The error is the exit code of the wrapper,
not of the command request ( that isn't executed )


Reproducing it with todays daily build from ~joeyh
breaks on the early command

 d-i preseed/early_command string mkdir /dim ; echo iets > /dim/notempty

( that is preseed.cfg content that worked with 20051017 )


Rerunning it with `preseed_command` is not possible.
Checking /var/lib/cdebconf/questions.dat revealed
that the value for "early_command" is gone.



This is on ia32.



It would be nice if it could be confirmed that this happens
on more places then just my place.



Cheers
Geert Stappers


--PmA2V3Z32TCmWXqI
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFDVWQ5OSINbgwa/7sRAlG9AJ93DVM95Fj/1Vo0Q7pYRs4QTLzK5gCfb58+
SprGgLZ1MFFz8m1osMLbtCE=
=8dVC
-----END PGP SIGNATURE-----

--PmA2V3Z32TCmWXqI--

---------------------------------------
Received: (at 334598-close) by bugs.debian.org; 19 Oct 2005 01:17:47 +0000
>From katie@spohr.debian.org Tue Oct 18 18:17:47 2005
Return-path: <katie@spohr.debian.org>
Received: from katie by spohr.debian.org with local (Exim 3.36 1 (Debian))
	id 1ES2Zs-0002rh-00; Tue, 18 Oct 2005 18:17:12 -0700
From: Joey Hess <joeyh@debian.org>
To: 334598-close@bugs.debian.org
X-Katie: $Revision: 1.56 $
Subject: Bug#334598: fixed in preseed 1.10
Message-Id: <E1ES2Zs-0002rh-00@spohr.debian.org>
Sender: Archive Administrator <katie@spohr.debian.org>
Date: Tue, 18 Oct 2005 18:17:12 -0700
Delivered-To: 334598-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Level: 
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Source: preseed
Source-Version: 1.10

We believe that the bug you reported is fixed in the latest version of
preseed, which is due to be installed in the Debian FTP archive:

env-preseed_1.10_all.udeb
  to pool/main/p/preseed/env-preseed_1.10_all.udeb
file-preseed_1.10_all.udeb
  to pool/main/p/preseed/file-preseed_1.10_all.udeb
initrd-preseed_1.10_all.udeb
  to pool/main/p/preseed/initrd-preseed_1.10_all.udeb
network-preseed_1.10_all.udeb
  to pool/main/p/preseed/network-preseed_1.10_all.udeb
preseed-common_1.10_all.udeb
  to pool/main/p/preseed/preseed-common_1.10_all.udeb
preseed_1.10.dsc
  to pool/main/p/preseed/preseed_1.10.dsc
preseed_1.10.tar.gz
  to pool/main/p/preseed/preseed_1.10.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 334598@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Joey Hess <joeyh@debian.org> (supplier of updated preseed package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 18 Oct 2005 21:08:04 -0400
Source: preseed
Binary: env-preseed file-preseed initrd-preseed network-preseed preseed-common
Architecture: source all
Version: 1.10
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joey Hess <joeyh@debian.org>
Description: 
 env-preseed - debconf preseeding via environment variables (udeb)
 file-preseed - load debconf preseed file (udeb)
 initrd-preseed - load debconf preseed file from /preseed.cfg on the initrd (udeb)
 network-preseed - download debconf preseed file (udeb)
 preseed-common - common files for preseeding (udeb)
Closes: 334598
Changes: 
 preseed (1.10) unstable; urgency=low
 .
   * log-output eval won't work now that it's rewritten in C. Instead,
     use log-output sh -c. Closes: #334598
 .
   [ Updated translations ]
   * Norwegian Nynorsk (nn.po)
   * Romanian (ro.po) by Eddy Petrisor
Files: 
 e9137be462420dd7e2b1fe409686a747 611 debian-installer optional preseed_1.10.dsc
 77be06a572c1077f1bda4b5a68de6f53 29071 debian-installer optional preseed_1.10.tar.gz
 0641a7578b2b98dcfed82ce1dc5139ab 12272 debian-installer standard preseed-common_1.10_all.udeb
 b7725b2ec1495df91b4e9fae2d8b995b 2636 debian-installer standard network-preseed_1.10_all.udeb
 76546f452128a2f6dbb54c72810ea835 2460 debian-installer optional file-preseed_1.10_all.udeb
 de82b5a060b8e93be86c7b1a48a05e40 900 debian-installer extra initrd-preseed_1.10_all.udeb
 25f824fe690d1d2652c47c4511149ef3 1410 debian-installer extra env-preseed_1.10_all.udeb
Package-Type: udeb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDVZ0b2tp5zXiKP0wRAmVNAKCve6ydt0l59uNMjeDpFu6vGLO1WQCeLV78
2UNqF+0VdcpuiKnwQxDOCys=
=Hcka
-----END PGP SIGNATURE-----



Reply to: