[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#334598: first stage preseed command failed with exit code 127

Package: debian-installer
Version: 20051017 & 20051018
Severity: normal


Preseeding "preseed/early_command" and "preseed/late_command" doesn't
seem to work....

Checking available examples show only comment lines.
( I have the feeling that preseed/...._commands aren't widely used )

The problem was first encounter in at the end of the first stage.

Syslog nicely reports the the command line as it in the preseed file
( no line wraps or other malformed isssues )

Rerunning 'preseed/late_command' in console VT2 with
gives the same error dialog box is the exit code 127

Editting the value of it in /var/lib/cdebconf/questions.dat
and reducing the string to just `wget http://host/path/file`
with another /usr/lib/prebaseconfig.d/05preseed
gives the same error message.

( `wget http://host/path/file` works fine )

The error is the exit code of the wrapper,
not of the command request ( that isn't executed )

Reproducing it with todays daily build from ~joeyh
breaks on the early command

 d-i preseed/early_command string mkdir /dim ; echo iets > /dim/notempty

( that is preseed.cfg content that worked with 20051017 )

Rerunning it with `preseed_command` is not possible.
Checking /var/lib/cdebconf/questions.dat revealed
that the value for "early_command" is gone.

This is on ia32.

It would be nice if it could be confirmed that this happens
on more places then just my place.

Geert Stappers

Attachment: signature.asc
Description: Digital signature

Reply to: