[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#253032: alpha test rc1 installation failed on various reasons

On Sun, Jun 06, 2004 at 08:38:53PM +0200, maximilian attems wrote:
> 1) detecting network loads module DAC960
>    don't know how that raid controller helps for networking?
>    anyway everything dead, last thing i could do was to change
>    consoles without seeing any grave message, i assume kernel panic
>    -> please blacklist that controller for network detection.
>    rebooted with DEBCONF_PRIORITY=medium to not load that module

The "detecting network hardware" is a bit of a misnomer, actually, as it
does detect other hardware and load drivers if they're available.

You say you were able to change consoles after this message appeared,
but the installer was dead?  Did the system freeze completely, or were
you still able to switch consoles?

> 3) install the base system fails after 70% because of apt-utils
>    vc3 shows:
>    Errors were encountered while processing: apt-utils
>    umount: /target/dev/pts: No such file or directory
>    umount: /target/dev/shm: No such file or directory
>    umount: /target/proc/bus/usb: Invalid argument

Is there anything above the "Errors were encountered while processing:"
line?  This error may be far back in the syslog output.  Is this related
to your installation of libdb4.2, mentioned below?

Ah, it seems this was the problem that prompted the debootstrap upgrade,
which was slow to arrive on alpha.  And due to personal time constraints
and autobuilder problems, the current debian-installer package has still
not been built on alpha, so this fix has not propagated into the sarge
d-i images.

... and building the current debian-installer package depends on having
a current version of the anna udeb in the archive for alpha; so it looks
like it may yet be a day or two before we can get usable sarge tc1
images into the archive for this arch. :/

Ok, I've gotten anna built and uploaded, and I'm short-circuiting to get
debian-installer built -- it's now uploaded as well.  Joey, can we get
the sarge CD build immediately following next dinstall declared tc1 for

> 4) boot loader menu entry jumps back to base-install instaed of calling
>    swriteboot witch correct arguments:
>    tried to install aboot from debian main-menu,
>    that asked if i want to proceed on an unclean base install,
>    which i thought to have cured above somehow, but arrrgh
>    it brings me back to 3)
>    redone aboves steps then outside of chroot:
>    sbin/swriteboot -c1 dev/sda boot/bootlx
>    (hmm it's a wild guess but seems to work somehow, 
>     stumbeled a bit but /dev/sda seemed not to exist only above /target)
>    edited /etc/aboot.conf to reflect the root partition on 1 partition.

The bootloader option depends on you first having a successfully
installed system.  It is possible to kludge this, but the correct fix is
to get a working base installer onto the CD as discussed above.

> 5) boot fails on kernel panic unable to mount root=/dev/sda1
>    when entering aboot, a quick 'l' lists aboot.conf entries
>    choosing 1 boots up the kernel, but
>    Please append a correct "root=" boot option
>    kernel panic: vfs unable to mount root fs on 08.01
>    also treid with bootargs 
>    devfs=mount,dall root=/dev/scsi/host0/bus/0/target0/lun0/partition1
>    but same result.

Do you know for sure that /dev/sda1 is the correct root partition for
your system?  What filesystem did you use?  This may also be an artifact
of the above errors (e.g., failure to build a correct initrd for the

Thanks for the feedback, max.  I'm sorry the installer couldn't be in
better shape for your testing, but I'm confident we'll have it working
again soon.

Steve Langasek
postmodern programmer

Attachment: signature.asc
Description: Digital signature

Reply to: