[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#253032: alpha test rc1 installation failed on various reasons

Package: installation-reports


Debian-installer-version: alpha test rc1 from may 30
uname -a: 
Date: 6. june 2004 ~16h
Method: sarge-alpha-businesscard.iso, boot from scsi cdrom,
	target ont scsi hard disc.

Machine: Digital Server 4000 - family Rawhide
Processor: 4
Memory: ~ 800 Mb
Root Device: SCSI Maverick hard disc
Root Size/partition table: 520mb from the end of a ~540 mb scsi drive
Output of lspci and lspci -n:

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [E] 1)
Config network:         [O/E] 2)
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O] 
Mount partitions:       [O]
Install base system:    [E] 3)
Install boot loader:    [E] 4)
Reboot:                 [E] 5)


this is the same machine as #242659 *)
unfortunately ended again without a working os on it.

1) detecting network loads module DAC960
   don't know how that raid controller helps for networking?
   anyway everything dead, last thing i could do was to change
   consoles without seeing any grave message, i assume kernel panic
   -> please blacklist that controller for network detection.
   rebooted with DEBCONF_PRIORITY=medium to not load that module

2) another error while installing the base system on a clean target:
   "couldn't download dpkg"
   the dhcpd daemon of that ass slow network is configured with
   "renewal in 150 seconds" so that may have interferred.
   on the next run i had more luck regarding network.

3) install the base system fails after 70% because of apt-utils
   vc3 shows:
   Errors were encountered while processing: apt-utils
   umount: /target/dev/pts: No such file or directory
   umount: /target/dev/shm: No such file or directory
   umount: /target/proc/bus/usb: Invalid argument

   changed to vc2, chrooted into /target, cd /var/cache/apt/archives,
   dpkg -i *deb
   apt-get install aboot libdb4.2 kernel-image-2.4.26-generic

4) boot loader menu entry jumps back to base-install instaed of calling
   swriteboot witch correct arguments:
   tried to install aboot from debian main-menu,
   that asked if i want to proceed on an unclean base install,
   which i thought to have cured above somehow, but arrrgh
   it brings me back to 3)
   redone aboves steps then outside of chroot:
   sbin/swriteboot -c1 dev/sda boot/bootlx
   (hmm it's a wild guess but seems to work somehow, 
    stumbeled a bit but /dev/sda seemed not to exist only above /target)
   edited /etc/aboot.conf to reflect the root partition on 1 partition.
5) boot fails on kernel panic unable to mount root=/dev/sda1
   when entering aboot, a quick 'l' lists aboot.conf entries
   choosing 1 boots up the kernel, but
   Please append a correct "root=" boot option
   kernel panic: vfs unable to mount root fs on 08.01
   also treid with bootargs 
   devfs=mount,dall root=/dev/scsi/host0/bus/0/target0/lun0/partition1
   but same result.

 hope that helps for further alpha development.
 best regards

*) i will close that bug report,
   as scsi disc were recognised after boot (no need to mount) 
   those base system trouble were cured,
   and the menu entry of aboot showed up.

Attachment: signature.asc
Description: Digital signature

Reply to: