[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#247949: marked as done (main-menu: eject command not available in installer shell)

Your message dated Sun, 6 Jun 2004 20:42:54 -0700
with message-id <20040607034254.GA24649@darjeeling.triplehelix.org>
and subject line done
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 8 May 2004 05:37:50 +0000
>From toff1@cox.net Fri May 07 22:37:50 2004
Return-path: <toff1@cox.net>
Received: from fed1rmmtao02.cox.net [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BMKX0-000086-00; Fri, 07 May 2004 22:37:50 -0700
Received: from iMacBlue ([]) by fed1rmmtao02.cox.net
          (InterMail vM. 201-2131-111-104-20040324) with SMTP
          id <20040508053718.KEJW7745.fed1rmmtao02.cox.net@iMacBlue>
          for <submit@bugs.debian.org>; Sat, 8 May 2004 01:37:18 -0400
Received: by iMacBlue (sSMTP sendmail emulation); Fri,  7 May 2004 21:36:06 +0000
From: "Chris Tillman" <toff1@cox.net>
Date: Fri, 7 May 2004 21:36:06 +0000
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: main-menu: eject command not available in installer shell
Message-ID: <20040507213606.GA544@ip68-107-134-103.tc.ph.cox.net>
Mime-Version: 1.0
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline
X-Reportbug-Version: 2.48
User-Agent: Mutt/
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.3 required=4.0 tests=BAYES_00,DATE_IN_PAST_06_12,
	HAS_PACKAGE autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-CrossAssassin-Score: 1

Package: main-menu
Version: debian-installer 4/28/2004
Severity: important

On powerpc, the eject command is critical to be able to remove
CDs from the computer. Many Macs are slot-based, there is no
button on the front which will eject the CD.

In the system I tested, where an installation had already been
completed using Sarge CD #1 built on 4/28/2004, I was unable
to eject the CD which had been booted in order to try another
CD. The eject command was not available in /bin, /sbin, 
/usr/bin, or /usr/sbin in the ramdisk system.

eject had been installed on the target hard disk, but was not
usable. I tried /target/usr/bin/eject from console #2, and 
it said it couldn't unmount it. I tried unmounting it first,
and it gave an ioctl error. I tried chrooting to /target,
but then the cdrom mount point (ramdisk /cdrom) was 
inaccessible. I couldn't eject the disk from the console.

This bug is written on main-menu, because boot-floppies
had a main menu item which called eject, and I believe
that would be an appropriate solution to this issue.

By the way, the CD should be ejected by the installer 
before it reboots into the new system.

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (990, 'testing')
Architecture: powerpc (ppc)

Debian GNU/Linux Operating System
  By the People, For the People
Chris Tillman (a people instance)
   toff one at cox dot net

Received: (at 247949-done) by bugs.debian.org; 7 Jun 2004 03:42:56 +0000
>From joshk@triplehelix.org Sun Jun 06 20:42:56 2004
Return-path: <joshk@triplehelix.org>
Received: from smtp812.mail.sc5.yahoo.com [] 
	by spohr.debian.org with smtp (Exim 3.35 1 (Debian))
	id 1BXB2G-0004Zn-00; Sun, 06 Jun 2004 20:42:56 -0700
Received: from unknown (HELO triplehelix.org) (edkwan@sbcglobal.net@ with login)
  by smtp812.mail.sc5.yahoo.com with SMTP; 7 Jun 2004 03:42:55 -0000
Received: from darjeeling.triplehelix.org (darjeeling.wifi.triplehelix.org [])
	by triplehelix.org (Postfix) with ESMTP id 037672DDD0
	for <247949-done@bugs.debian.org>; Sun,  6 Jun 2004 20:42:54 -0700 (PDT)
Received: from joshk by darjeeling.triplehelix.org with local (Exim 3.36 #1 (Debian))
	id 1BXB2E-0006Pl-00
	for <247949-done@bugs.debian.org>; Sun, 06 Jun 2004 20:42:54 -0700
Date: Sun, 6 Jun 2004 20:42:54 -0700
To: 247949-done@bugs.debian.org
Subject: done
Message-ID: <20040607034254.GA24649@darjeeling.triplehelix.org>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="ikeVEW9yuYc//A+q"
Content-Disposition: inline
X-Habeas-SWE-1: winter into spring
X-Habeas-SWE-2: brightly anticipated
X-Habeas-SWE-3: like Habeas SWE (tm)
X-Habeas-SWE-4: Copyright 2002 Habeas (tm)
X-Habeas-SWE-5: Sender Warranted Email (SWE) (tm). The sender of this
X-Habeas-SWE-6: email in exchange for a license for this Habeas
X-Habeas-SWE-7: warrant mark warrants that this is a Habeas Compliant
X-Habeas-SWE-8: Message (HCM) and not spam. Please report use of this
X-Habeas-SWE-9: mark in spam to <http://www.habeas.com/report/>.
User-Agent: Mutt/1.5.6+20040523i
From: Joshua Kwan <joshk@triplehelix.org>
Delivered-To: 247949-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-3.0 required=4.0 tests=BAYES_00 autolearn=no 

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

eject-udeb is now installed on PowerPC CDs and CD driver floppies, so
this issue has been resolved.

Joshua Kwan

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.2.4 (GNU/Linux)
Comment: http://triplehelix.org/~joshk/pubkey_gpg.asc



Reply to: