[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: bf2.4 dbootstrap white screen of death

On Fri, Feb 08, 2002 at 05:45:07PM +0100, Eduard Bloch wrote:
> #include <hallo.h>
> Mark Zimmerman wrote on Fri Feb 08, 2002 um 08:39:07AM:
> > Greetings:
> > 
> > I tried out a new installation on an IBM Thinkpad 560X with the bf2.4
> Which kind of VGA chipset is used there? Anyways, if you come to the
> floppy change prompt, framebuffer is allready working for you.
> > linux floppy=thinkpad
> > linux floppy=thinkpad,mono
> > 
> > Can anyone suggest a workaround for this?
> Please try with "video=vga16:off" and report the result.

I ran a bunch of new tests and here are the results:

linux floppy=thinkpad,video=vga16:off

results in the white screen as previously described. However, looking
through dmesg yielded the clue that this is an ill-formatted set of
options (comma should be space). So, I tried:

linux floppy=thinkpad video=vga16:off

and it booted to the point where it asks for the root floppy, but when I
put it in I got I/O errors and a kernel panic. Apparently I ought not to
use floppy=thinkpad on my thinkpad and the original badly formatted
command kept it from using it. Next, I tried

linux video=vga16:off

and it loaded the root floppy successfully but things went astray after
that. VT1 gets to the point where it says:

init started: BusyBox ...(etc)

VT2 repeatedly asks me to press Enter to activate this console but will
not give me a shell.

VT3 shows that dbootstrap is repeatedly starting and exiting.

Finally, I tried booting with no options. This returned me to the
original white screen problem. This time, I thought to look at VT3 for
the logs and found that dbootstrap started and exited several times. The
last log message shows that it exited and was scheduled for restart. A
ps ax in VT2 shows it running though.

I also tried (finally++) so see if I could get going with a serial
console (console=ttyS0,9600). When I tried that, I got nothing on the
screen and nothing out the serial port either. Same with ttyS1.

-- Mark

Reply to: