[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: not i18ned part in b-f 2.2.15


On Wed, 09 Aug 2000 20:26:03 +0900
Taketoshi Sano <sano@debian.org> wrote:

> Hi.
> In <oag0ofesy6.fsf@arroz.fake>,
>  on "08 Aug 2000 10:19:29 -0400",
>  with "Re: not i18ned part in b-f 2.2.15",
>   Adam Di Carlo <adam@onshore.com> wrote:
> > Akira YOSHIYAMA <yosshy@cts.ne.jp> writes:
> > 
> > > Surely, we can do with basedisks.sh hacking. But, it makes the script
> > > more complex and dirty.
> > 
> > Are we talking about woody or potato?  If woody, then sure, lets find
> > a cleaner way to do it.  If woody, however, it doesn't matter all that
> > much since the system will be gutted very soon, and basedisks.sh will
> > cease to exist.
> I think I am talking about potato (it may be a point release), 
> and yes I think the quick and easy hack can be done for potato b-f.
> Since the overall rewrite will be done for woody, doing it at this
> stage is not effective approach.
> Can you provide me a patch to modify basedisks.sh, yosshy ?

Basically, the change in basedisks.sh for termwrap is only copying
termwrap from scripts/basedisks to the base archive. Another work
to support termwrap is changing in

> > > If we have i18ned console tools, termwrap is a very good choice.
> > > It's better than every tool considers terminal emulator for users.
> > > 
> > > And then.... we can merge termwrap and sensible-x-terminal-emulator.
> > > It provides us more unified i18n terminal environment.
> > 
> > Quite.  But the woody vs potato argument comes up again.  I doubt such
> > a change can be made in potato X11 packages at this point.
> Maybe not.  Anyway, since termwrap has benefit on potato base system,
> I think we can work to put it in our boot-floppies.

Agree. Surely, termwrap is useful not only in boot-floppy but others.
But, in this time we can add it to the boot-floppy only. And it's valuable
for i18ned _potato_ installer.

I think that the potato installer may not contains termwrap for stable initial
release. But, you know, we need much period for the woody release. We
have to update the potato installer, and we will be able to try b-f to support
i18ned messages with latest debconf and termwrap.

Best regards,

	A.Yoshiyama <yosshy@debian.or.jp>

Reply to: