[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Install problems: Potato / boot disks 2.2.5

Hey Adam,

> Obviously, we can't support mix-and-match slink / potato
> installations.  At this point, the sole concern of this group is the
> potato boot-floppies.

I used the slink install as a 'last-resort' .. after numerous attempts of
installing potato failed, I wanted to see how a slink install would go
(since I've installed slink on all our other systems I figured it would work
.. my goal, was to get an os on the system, anyway I could).  I then found
that the kernel I had on my custom-slink cd would panic .. rather than
building another set of slink boot floppies I figured I'd use the kernel
from potato (since it would boot without problems) to boot and install slink
from there .. I wanted to prove (to myself) that the hardware was indeed ok
and that perhaps there were some problems with what the potato install
does.. and from trying that method, I did find that the slink install was
able to format and mount the drives without any error .. (well, not really
the install .. but the versions of mke2fs and mount on slink worked without
err .. the equivalents on potato caused errors).

> I would appreciate, Terry, if we could focus on the install problems
> in onto your system in the pure potato world.  You say:
> > The cd boots up fine (built it today, with the stock boot-floppies
> > 2.2.5), both raid volumes are found and install works fine through
> > formatting and activating of the swap partition... However, as soon
> > as it mounts the raid filesystems (/ and /usr), a whole slew of e2fs
> > errors appear on the screen (not sure the exact error, it was
> > something about the inode-bitmap and wrong free block count).
> I have absolutely no idea what this is -- any clues, anyone?
> > I can continue with the install but when it copies files to the hard
> > drive I get more of those errors (It gets into a loop asking me to
> > configure device drivers .. just keeps asking even after I install
> > the nic drivers).
> This sounds like unrelated problems in modconf to me.  I hope these
> are fixed in the new modconf.  We'll be burning a new boot-floppies
> 2.2.6 with this problem I hope fixed.
> However, for your report to be more effective, I really do need more
> explicit information regarding at exactly what stage the errors were
> emitted, and what the error messages exactly were.

I initially emailed from home, so i didn't have the error message handy ..
When I get to the office, Monday, I will re-attempt the install and copy
down the errors that happen.  The exact stage that I began seeing the
errors, however, started after the format, when the installer asked if I
wanted to mount the partition as the root file system.

I was able to 'force' the errors outside of the installer by dropping to a
shell and issuing some basic commands .. I first formatted the partition
(mke2fs /dev/sda1).. that went fine, no errors.. then I mounted it under
/target (mount /dev/sda1 /target), which produced a couple screens full of
e2fs errors (which I will clarify on Monday).  I then umounted the
filesystem, and ran an fsck on it.  Fsck had continuous 'inode has dtime
set' errors on the partition (again, will clarify the error Monday).  As a
sanity check on the format, I would then reformat (again, without error),
and then run an fsck on the newly formatted partition .. no errors .. try to
mount, tons of errors.. etc...

In the installer, after mounting the partition (and getting errors), and
further access to the disk (copying the kernel, the base system, the
drivers, etc...) would result in screens full of errors..  I was assuming
that perhaps the modules (or something) wasn't copied over (or modified)
correctly .. and then for some reason the installer didn't think I
configured the modules and just kept having that as the next step ..

I was thinking that this could be a problem with the MegaRaid driver in the
kernel .. I wanted to get anything installed, so thats why I tried slink ..
figured I'd install that, upgrade to potato, and then try formatting and
mounting another partition under potato (perhaps there's a problem between
the driver and the new ext2 format stuff?)


Reply to: