[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [GSoC] blends-gsoc documentation

Hi Emmanouil

On Wed, Sep 18, 2013 at 05:56:44PM +0300, Emmanouil Kiagias wrote:
> Note: I fixed a dummy bug in blends-gsoc/tasks_diff, I found it while
> testing the changelogentry target for all Blends (it's weird that I did not
> noticed this in previous tests)

this just happens - good that you fixed it!
> > The Blends which exist in git are OK, here is a summary:
> >
> > * fun : (nothing to do for this)
> > * debian-pan : Initinal release (so this is fine)
> > * debian-games : Initial release (so also it is also fine)
> > * debian-gis : I committed  all the dependency json files (also for
> > previous releases 0.0.2,0.0.3 corresponding tasks taken from git tags)
> >
> >
> I finished adding all the needed files to the Blends in svn:
> * debichem
> * debian-science
> * openstudio : initial release, nothing to do here
> * debian-junior
> * debian-accessibility : initial release
> * debian-imaging: initial release
> * debian-lex : initial release

> For debian-ezgo although there are 3-4 releases none of them is tagged in
> svn, so how do we distinguish here which are the task files for the
> previous release? I was thinking of getting the revision number when the
> previous release was added in the debian/changelog and just  get the tasks
> files for that revision number.

Hmmm, shame on ezgo maintainers.  Perhaps you might contact them whether
they reproduce / fake tags.  If all else fails you could create the tag
directories and inject the files from snapshot.debian.org.

> Also for debian-multimedia you were right the
> git.debian.org/git/pkg-multimedia/multimedia-blends.git url is working. The
> problem is that when I tried to git push origin master to update the remote
> repo I get the following error:
> error: insufficient permission for adding an object to repository database
> ./objects
> fatal: failed to write object
> error: unpack failed: unpack-objects abnormal exit
> To git+ssh://
> ekiagias-guest@git.debian.org/git/pkg-multimedia/multimedia-blends.git
>  ! [remote rejected] master -> master (n/a (unpacker error))
> error: failed to push some refs to 'git+ssh://
> ekiagias-guest@git.debian.org/git/pkg-multimedia/multimedia-blends.git'
> Any ideas on this? I will check it again.

Yes.  Become a member of debian-multimedia team. ;-)

It is in their area (as an exception, same as debian-edu).  People in
Debian Multimedia considered this an advantage for whatever reason but
in this specific case it is probably a disadvantage.  May be posting
the issue to their list and add the patch might be sufficient.
> All the rest of the Blends should now work properly with all the make
> targets, all the needed files are there now.

I'm afraid I will not manage to carefully test them all before my VAC
starts at Friday.  I'll discuss with Sukhbir what steps would be
required to formalise finish the GSoC mentor part (because I might be
offline(ish) for the next three weeks).

Kind regards



Reply to: