[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apex-nslu2 error

Hi Al

On Thu, Sep 17, 2009 at 01:58, Al <vanilla.source@gmail.com> wrote:
> Gordon Farquharson wrote:
>> That's really odd. Can you try again, and email the contents of the
>> temporary file that is created, i.e. the contents of the file listed
>> in the line "+ tmp=/tmp/filelburYO". In the example above, the
>> temporary file is named "/tmp/filelburYO", but the file name will be
>> different every time. If the new temporary file doesn't exist, let me
>> know.
> It does create a new file every time I run the command, but it's always a
> zero-byte file, so no contents to show you.

Thanks for the information. I think I know what is going on. egrep is
not finding a match (i.e. all lines contain "*=") and so is returning
1. The flash-apex script has been told to exit if any command returns
a non-zero value (see "set -e" at the top of the script). So what I
need to do is to deal with the return value of egrep. I'm confused how
this ever worked.


Gordon Farquharson
GnuPG Key ID: 32D6D676

Reply to: