[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#239416: apache: Apache failling to upgrade

> Ok let's try another approach...
> apt-get install apache-common
> this should bring apache-common to the latest version.
> Add set -x to /usr/share/apache/postinst.common
> apt-get install apache
> (to trigger again it's postinst script, be aware that it will produce
> quite a lot of output and we need to see all of it).
> I really can't see where the problem is...

apache-common was already installed, so apt-get install apache-common made

Chowing a -x to /usr/share/apache/postinst.common and then an apt-get
install apache just keep giving the same error (that was unable to
configure apache, etc).

So, apt-get --purge remove apache apache-common

All apache was removed.

apt-get install apache apache-common

Everything runs fine. It installed.

apt-get install php4 worked good too.
That looked very strange to me.
I did a diff from the old /etc/apache and the new one. It's attached.
Looking on it, I did not find something wrong.

I have moved the old /etc/apache files to /etc/apache, overwriting the new
installed and apache is perfect now.

I really don't know what could be.
The --purge only removes /etc/apache config files or it removes some other
files too? I am thinking that the error could be on other files that are
used internally to apt-get.


Attachment: diff.gz
Description: Binary data

Reply to: