Re: Bug#239416: apache: Apache 220.127.116.11.2-4 failling to upgrade
Ok let's try another approach...
apt-get install apache-common
this should bring apache-common to the latest version.
Add set -x to /usr/share/apache/postinst.common
apt-get install apache
(to trigger again it's postinst script, be aware that it will produce
quite a lot of output and we need to see all of it).
I really can't see where the problem is...
On Mon, 22 Mar 2004, Nelson A. de Oliveira wrote:
> The error old error was better than that: :-)
> Starting web server: apache failed
> invoke-rc.d: initscript apache, action "start" failed.
> dpkg: error processing apache (--configure):
> subprocess post-installation script returned error exit status 1
> dpkg: dependency problems prevent configuration of libapache-mod-ssl:
> libapache-mod-ssl depends on apache (>= 18.104.22.168.1-4) | apache-perl (>=
> 22.214.171.124.1-4); however:
> Package apache is not configured yet.
> Package apache-perl is not installed.
> dpkg: error processing libapache-mod-ssl (--configure):
> dependency problems - leaving unconfigured
> Errors were encountered while processing:
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> I don't know what could be.
> I always upgraded Apache with apt-get dist-upgrade and never touched it
> config files.
> But since 126.96.36.199.1-4 was released, that error keeps.
<user> fajita: step one
<fajita> Whatever the problem, step one is always to look in the error log.
<user> fajita: step two
<fajita> When in danger or in doubt, step two is to scream and shout.