[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: Re: blank DVDs no recognized, other media OK

On Wed, Aug 30, 2006 at 12:20:46AM +0900, Craig Hagerman wrote:
> I checked that. There IS some hald processes running.... but what
> exactly does this mean?
> $ ps ax | grep hald
> 2870 ?        Ss     0:00 /usr/sbin/hald
> 2871 ?        S      0:00 hald-runner
> 2877 ?        S      0:00 /usr/lib/hal/hald-addon-acpi
> 2886 ?        S      0:00 /usr/lib/hal/hald-addon-keyboard
> 2894 ?        S      0:02 /usr/lib/hal/hald-addon-storage

hal is a hardware abstraction system for monitoring hotplug events of
devices, and auto mounting new devices, telling the user (if running
gnome or kde or something else hal/opendesktop aware) about the
insertion to let them decide what to do.  It has an annoying tendancy to
very frequently ask the cd/dvd drive if there is a disk in there to
mount uet, which causes problems for writing CD/DVD a lot of the time.
It could potentially cause problems for DVD movies if the drive needs to
be left alone to do CSS key lookups or something.

> It IS a newer kernel. I compiled it about 6 months ago and
> it worked just fine from that time vis. CD/DVD tasks.

Well try stopping hald.  There is probably an init.d script you can call
to stop it.

> Already tried that. Tried growisofs as root from the command line.
> Said there was no media present (there was).

Try it again without hald running.  Worth a try after all.

Len Sorensen

Reply to: