[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Strange problem that don't allow me to mount dvd units



First, sorry If I wrote to your personal email. I am waiting reply in
"debian amd64" mail list. (See below)

Lee Begg wrote:
> On Wed, 09 Nov 2005 00:16, dclemen wrote:
> 
>>More info: dmesg
>>
>>Bootdata ok (command line is root=/dev/sda3 ro console=tty0 )
> 
> <snip>
> 
>>Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
>>ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
>>JFS: nTxBlock = 8013, nTxLock = 64111
>>Adding 1775172k swap on /dev/sda2.  Priority:-1 extents:1
>>Probing IDE interface ide0...
>>hda: TOSHIBA ODD-DVD SD-M1802, ATAPI CD/DVD-ROM drive
>>Probing IDE interface ide1...
>>hdc: HL-DT-ST DVDRAM GSA-4163B, ATAPI CD/DVD-ROM drive
>>Probing IDE interface ide2...
>>Probing IDE interface ide3...
>>Probing IDE interface ide4...
>>Probing IDE interface ide5...
>>ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
>>ide1 at 0x170-0x177,0x376 on irq 15
>>ide-scsi is deprecated for cd burning! Use ide-cd and give dev=/dev/hdX
>>as device
> 
> 
> Since ide-scsi is not in your bootparams (the "command line" above), my guess 
> is that you have ide-scsi in /etc/modules.  If you do, remove it. Then 
> reboot.
> 
> If that isn't the case, did you compile your kernel? Maybe you turned ide-scsi 
> on?
> 
> As of 2.6.0, noone should use ide-scsi (unless it doesn't work at all without 
> it).
> 
> Hope this helps.
> 
> Later
> Lee Begg

No I don't compile kernel, I get it as .deb package (2.6.12-1).

ide-scsi are not in /etc/modules, but it is loaded (restart system but
loaded again). This is my modules file:

$ cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line.  Comments begin with
# a "#", and everything on the line after them are ignored.

ide-cd
ide-disk
ide-generic
psmouse
sd_mod


When I try to remove this module I get this error
# rmmod ide-scsi
Terminado (killed)

Message from syslogd@localhost at Tue Nov  8 14:29:32 2005 ...
localhost kernel: Oops: 0000 [1]

Message from syslogd@localhost at Tue Nov  8 14:29:32 2005 ...
localhost kernel: CR2: 0000000000000370

Message from syslogd@localhost at Tue Nov  8 14:29:37 2005 ...
localhost kernel: Oops: 0000 [2]

Message from syslogd@localhost at Tue Nov  8 14:29:37 2005 ...
localhost kernel: CR2: 0000000000000370

And module are not removed:
# lsmod | grep ide
ide_generic             1600  0 [permanent]
ide_disk               18048  0
ide_cd                 43552  0
cdrom                  39544  2 sr_mod,ide_cd
ide_scsi               18116  0
ide_core              144888  5 amd74xx,ide_generic,ide_disk,ide_cd,ide_scsi
scsi_mod              151512  5 sg,sr_mod,ide_scsi,sd_mod,libata

Maybe as Dean Hamstead said, I have to rebuild initrd? (remove/rename
/lib/modules/2.6.12-1-amd64-k8/kernel/drivers/scsi/ide-scsi.ko file, and
mkinitrd?)

Thanks for replies!!!

(I boot with old 2.6.8 kernel and not load ide-scsi module, devices are
hda and hdc and work fine)



Reply to: