[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Networking not working

On Nov 5, 2005, at 11:12 AM, Thomas F. O'Connell wrote:

On Nov 5, 2005, at 10:46 AM, Thomas F. O'Connell wrote:

On Nov 5, 2005, at 8:49 AM, Austin (Ozz) Denyer wrote:

On Fri, 4 Nov 2005 20:54:16 -0600, "Thomas F. O'Connell"
<tfo@sitening.com> wrote:

So I finally made it through the installation process (see nearby
thread about software RAID, LVM, and LILO), and lo and behold:
networking isn't working. The primary ethernet card (of three) in
this machine is an Intel Ethernet Pro 100, and the e100 module seems
to load fine and be recognized, but I don't seem to be able to ping
the router on my local network, so I'm suspicious of the network card.

During installation, DHCP was not detected, and after reboot during
base-config, apt setup couldn't be completed normally because, I
suspect, of networking issues.

Has anyone had any difficulty getting networking going under sarge

It would help greatly if you could give us some error messages to chew

Well, here's what happens:

During installation, it gets to the point where it recognizes and displays my three network interfaces. I choose the e100, which has traditionally been eth0, as the primary interface. Looking on the Alt-F3 virtual console, I see the following lines:

insmod /lib/modules/2.6.8-11-amd64-generic/kernel/drivers/net/mii.ko
insmod /lib/modules/2.6.8-11-amd64-generic/kernel/drivers/net/e100.ko
insmod /lib/modules/2.6.8-11-amd64-generic/kernel/drivers/net/tg3.ko

Then, back on the installer console, it tells me that it's going to detect DHCP. This fails. There are no further messages or errors on the other console other than:

insmod /lib/modules/2.6.8-11-amd64-generic/kernel/drivers/block/ floppy.ko FATAL: Error inserting floppy (/lib/modules/2.6.8-11-amd64-generic/ kernel/drivers/block/floppy.ko): No such device

But that's not related to DHCP detection, is it?

Then I try to configure the network manually with the IP the box had before I attempted to reinstall, along with the local network address for the router and the correct netmask. I leave the nameserver blank.

The installer pauses for a bit and then returns with the hostname prompt.

Is there any way to determine at this point in the installation process whether the network card has been successfully recognized and is working? Or to further diagnose why DHCP was not able to be autoconfigured? Would expert mode help?

For what it's worth, I am now having the same problem with the sid amd64 testing netinst image.

Okay. I'm a little closer to tracking it down, now. For comparison with sarge and sid, I tried the Ubuntu AMD64 installer CD. The installer is, of course, very similar to Debian, but the Ubuntu installer chose a different ordering for my network cards, putting one of the Broadcom NetXtreme cards as eth0 rather than the Intel Ethernet Pro 100. I had just been assuming that the Intel was the card I had been using before reinstalling this system, but I guess it's been one of the two Broadcoms because DHCP autoconfiguration worked.

If I can be of assistance in improving default selection of the primary network interface for the Debian Installer, please let me know. I don't know if this is an amd64 issue or not, so also please let me know if I should post the results of all these attempts on another list.

Thomas F. O'Connell
Database Architecture and Programming
Sitening, LLC

110 30th Avenue North, Suite 6
Nashville, TN 37203-6320
615-469-5151 (fax)

Reply to: