[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Need some help with MD raid1 or h/w prob

Look you grump, we don't get paid. you will not get 12 hour turn around time on questions unless they are extremly simple, or extremly well discribed.

 about your raid problems:
how did you originaly create them (from fresh install, or from booting a cd)?
  have the raid devices ever worked correctly?
  Alot of times if you've specified your to boot
    vmlinuz root=/dev/sda2
   instead of
    vmlinuz root=/dev/md1
the raid array will not come up correctly. (makes sense, it's already mounted the drive) If you are sure you've specified md1 at the boot prompt, perhaps you just need to raidhotadd the second drive (raidhotadd md0 /dev/sda1). Also make sure that you have either an initrd set up for your raid, or a raid enabled kernel or you won't be able to mount your root and may be fairly hosed.

also when you want to fsck a filesystem and it's telling you it's marked as clean you need to pass it the -f flag to force it. Also you'll want to run that command on the raid device not the individual partitions.

please read the software raid howto for more info. You will probly be interested in lvm for partitioning. I've only use ext3 with lvm, but i've heard good things about reiserfs.


Rupert Heesom wrote:

Well, nobody seems to know how to help me, but I've sorted some of this
out myself.  Ran DOS Maxtor diag util on both my disks.  Errors on both
which seem now to be solved.

I've also discovered EVMS, so learning about that to solve my partition

On Wed, 2005-06-15 at 22:34 +0100, Rupert Heesom wrote:
My disk setup is:

mount -

/dev/md1 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/md0 on /boot type ext2 (rw)
/dev/mapper/VolGrp1-HOMELogVol on /home type ext3 (rw)
none on /dev type tmpfs (rw,size=10M,mode=0755)

I've been having problems with putting Openvpn bridging together, and
had the <remove bridge> command hanging on me to the point that I
rebooted the machine a couple of times - the process just wouldn't
quit,so I ended up shutting power down.

Reply to: