[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Need some help with MD raid1 or h/w prob

My disk setup is:

mount -

/dev/md1 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/md0 on /boot type ext2 (rw)
/dev/mapper/VolGrp1-HOMELogVol on /home type ext3 (rw)
none on /dev type tmpfs (rw,size=10M,mode=0755)

I've been having problems with putting Openvpn bridging together, and
had the <remove bridge> command hanging on me to the point that I
rebooted the machine a couple of times - the process just wouldn't
quit,so I ended up shutting power down.

End result is that, after a couple of times of this, when I booted up,
the machine hung when trying to load nmdb (samba).  Error msgs was
something like :  (from written notes)

Current SDA:  sense key Medium Error
Additional sense:  unrecovered read error - auto reallocate failed.
end_request: I/O error, dev sda sector 2014956
scsi0:  ERROR on channel 0, id 0, lun0, CDB:  lead.....
end_request: I/O error, dev sda sector 2014957
raid1: sda2 rescheduling sector 1822168
raid1: sda2 rescheduling sector 1822168 to another mirror
ata1(0): WARNING zero len r/w req


I booted into "recovery" mode which let me press Cntl-D to get to root
prompt early.  I then tried to look for errors & ran fsck etc.  I had a
look at mdadm, but rather than checking filesystems, its more for
managing raid arrays (not surprisingly!).

I umounted /dev/md0, and /dev/md1, and ran fsck on them, but everytime
the results came up with a very quick "clean" etc.

One thing I did see using mdadm was that my "arrays" are actually 1
active, 1 spare disk, rather than 2 active.   I tried to look for a way
in mdadm to add the spare disk onto the active array, but couldn't find
a way (how do I???).

So, I'm looking to find a way of dealing with the disk problem

In "single" mode, I disabled samba in /etc/init.d so that startup would
bypass that particular problem.  The machine now gets as far as X
(Gnome) and into Evolution as well hitting no apparant problems.

Can I get some help in trying to sort this mess out?

Much appreciated!   So much to learn, so little time!

Rupert Heesom rupert@heesom.org.uk

Reply to: