[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gcc version issue trying to install vmware5

Leopold Palomo-Avellaneda <lepalom@wol.es> writes:

> A Dimarts 14 Juny 2005 11:20, Goswin von Brederlow va escriure:
> [....]
>> The default compiler is gcc-3.3 and everything in debian uses that. ....
> Sure? 
> I think that the kernel doesn't and the nvidia modules _need_ the 3.4 version. 

The gernel doesn't use gcc. It uses gcc-3.4 because that is the only
one that can build 64bit kernels on i386.

Any kernel modules you build also have to use gcc-3.4 and not gcc.

But that doesn't mean gcc-3.4 should be THE gcc.

> It's a bit confuss to have in this platform two versions of the compiler and 
> choose the best for each circumstance. Maybe, if the 3.3 and the 3.4 versions 
> have problems in _our_ platform, we should think again to make some effort in 
> the a 4.x version of the dist to have only one compiler for _ALL_ the distro.

Debian already defines one gcc version to be used for a release, that
is what gcc links to. Gcc-3.4 is only used in special circumstances
where it is needed and where it doesn't affect the rest of the system.

The choice was to use gcc-3.4 or to not have a kernel-image-2.6-amd64
in debian sarge. Same for mozilla and derivates. I think everyone
agrees that using gcc-3.4 was the better alternative.

For etch the plan is to switch to gcc-3.4 (or later) completly. All
c++ libraries need to be recompiled for that.

> And I'm writing this with good sense, the last think I want is a flame. I 
> would like to make just a reflexion. Maybe, I'm wrong.


Reply to: