[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debconf and other outdated packages

On 05-Feb-10 23:08, Javier Kohen wrote:
> Great!
> Is it possible that some packages are still missing? For instance the X 
> server is -8, whereas pure64 has -10.
> When I upgraded pure64 to gcc-3.4 I had to leave the -10 packages 
> installed because they have some important fixes. Today I was trying to 
> find out why wxwidgets2.5's compilation is failing (see below), but I 
> couldn't readily install the -dev packages I need to compile it because 
> I don't have the X's -dev packages corresponding to the binaries I've 
> installed. Maybe I should also install X's -dev packages from pure64 for 
> now.
> On a second look to wxwidgets2.5 compilation's log in 
> gcc-3.4/buildd-logs it looks like it's downloading the build 
> dependencies from pure64, as it's actually fetching the -10-dev X 
> packages. Anyway, in case somebody knows before hand about this problem, 
> the error message is:
> checking for strcasecmp() in string.h... no
> checking for strcasecmp() in strings.h... no
> configure: error: No case-insensitive string comparison function found.
> make: *** [configure-gtk-shared-stamp] Error 1

I have compiled the X -10 version but when I installed it on my own
workstation, something went wrong and I could not start X anymore.
Because of this, I did not yet upload the new version. In the meantime
I found that the 'bdftopcf' binary in my -10 version does not work 
properly and consequently X does not find some necessary fonts on 

I will upload -10 as soon as I have fixed this.

Thanks again for the report.

Andreas Jochens

Reply to: