[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Inconsistencies in FAQ/HOWTO.

Hi all,

My Hypersonic-PC Aviator AX6 laptop (with an Athlon64 3200+) finally
arrived this week.  I have i386 Sarge installed via the beta2
debian-installer with essentially no Debian related problems worth
mentioning.  BTW, does anyone else here use this hardware?

Since then, I've tried to follow the AMD64 FAQ/HOWTO on alioth in
order to build a 64 bit kernel.  I've found some inconsistencies with
it and my experience.  I eventually could produce a bootable
monolithic kernel however it has problems when the network driver
(via-rhine) was used.  I'll try Linux 2.6.3 first, before reporting on
this driver problem in detail.

For now, here are the inconsistencies with the documentation I found.
Some are obviously trivial, some less so.

 0) Under "Configure the kernel" the 2nd and 3rd paragraphs are

 1) After cdebootstrap'ing (also tried debootstrap) i386 woody into an
 empty partition, mounting proc, chrooting and finally apt-get'ing the
 required packages my i386 woody chroot doesn't have "make" nor the
 "gcc" symlink.

 2) I needed to explicitly setup /etc/resolve.conf in the chroot.

 3) The gcc.bart needs to be "chmod +x"ed after downloading and moving
 to /usr/bin/gcc.

 4) The building of bzImage failed with the instructed command:

	ARCH="x86_64" make HOSTCC="gcc -m32" bzImage

 The reason is that the ARCH definition was not making its way into
 the gcc (gcc.bart) script.  However re-arranging the command to:

	make ARCH="x86_64" HOSTCC="gcc -m32" bzImage

 works.  From what I know about how make and bash work this shouldn't
 matter, so I'm not sure what to make of it.

Below are selected parts of the session in case they prove illuminating.

(setup the chroot partition, including adding the proc in the fstab, then)
aviator:~# cdebootstrap woody /chroot/deb-biarch http://mirror.phy.bnl.gov/debian/ 
(no mention of make nor gcc related packages, no obvious errors)
aviator:~# grep proc /etc/fstab
proc    /proc   proc    defaults        0 0
aviator:~# mount proc-biarch
aviator:~# cp /etc/hosts /chroot/deb-biarch/etc/hosts
aviator:~# chroot /chroot/deb-biarch /bin/bash
aviator:/# PS1="chroot:\w# "
chroot:/# DEBIAN_FRONTEND=readline apt-setup
(point to my mirror)
(this failed until I did:)
aviator:~# cp /etc/resolv.conf /chroot/deb-biarch/etc
aviator:/# echo "deb http://debian-amd64.alioth.debian.org/ sarge main" >> /etc/apt/sources.list
(I didn't run dselect, but just did:
aviator:/# apt-get update
aviator:/# apt-get install libc6 libc6-dev gcc-3.3 libncurses5-dev wget bzip2
(decide I should remind myself where I am)
aviator:/# PS1="chroot:\w# "
chroot:/# which make
chroot:/# which gcc
chroot:/# ls -l /usr/bin/gcc
ls: /usr/bin/gcc: No such file or directory
chroot:/# apt-get install make

I didn't install "gcc" because it would pull in gcc 2.95 which doesn't
seem called for (?).  

Next the kernel:  I used 2.4.23 and 2.4.25 with similar problems.
This session is with 2.4.23 and I explicitly name gcc-3.3:

chroot:/usr/src/linux# make HOSTCC="gcc-3.3 -m32" ARCH="x86_64" menuconfig
...configure minimal monolithic kernel...

Get and install gcc.bart
chroot:~# wget http://www.jukie.net/~bart/debian/amd64/scripts/gcc.bart
chroot:~# mv gcc.bart /usr/bin/gcc
chroot:~# chmod +x /usr/bin/gcc
chroot:~# cd /usr/src/linux
(use switched order of defining ARCH)
chroot:/usr/src/linux# make ARCH="x86_64" HOSTCC="gcc -m32" bzImage
(kernel build seems to progress fine).


Reply to: