[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Upgrading Sarge to Etch - failing to boot new kernel


the best is to not use the (I call it "deprecated") old-style linux device names. Use /dev/disk/by-uuid/.... for the specification of the root filesystem (each filesystem has a unique ID assigned on creation). Alternatively assign a name to the file system using tune2fs/e2label and specify as /dev/disk/by-name/...., so it has a nice name. The management of the symbolic links in /dev is done by UDEV which is booted by the initrd.

Here is my aboot config of the kernel line on my AlphaStation (should be similar with MILO):

0:2/vmlinuz ro initrd=/initrd.img root=/dev/disk/by-label/root

These directory listings are dynamically created by UDEV, so you should prefer these ones. Recent installations of Ubuntu (not sure if also Debian) automatically use them:

thetaphi@alpha:~$ ls -l /dev/disk/by-label/ insgesamt 0 lrwxrwxrwx 1 root root 10  8. Jun 07:27 boot -> ../../sda2 lrwxrwxrwx 1 root root 10  8. Jun 07:27 root -> ../../sdb1

thetaphi@alpha:~$ ls -l /dev/disk/by-uuid/ insgesamt 0 lrwxrwxrwx 1 root root 10  8. Jun 07:27 09311049-3762-4d4d-877e-a4b02a4db4f1 -> ../../sdb1 lrwxrwxrwx 1 root root 10  8. Jun 07:27 b8c0bb84-297a-44e5-b83e-d7aa1e352248 -> ../../sda2

If you have multiple network cards it's also a good idea to assign static names using UDEV configuration based on their MAC address, ethX is ugly :-)

Uwe Schindler
H.-H.-Meier-Allee 63, D-28213 Bremen
eMail: uwe@thetaphi.de>

 -----Original Message-----
> From: Piotrek Gliźniewicz [mailto:glizda@gmail.com]
> Sent: Monday, June 21, 2010 10:04 PM
> To: debian-alpha@lists.debian.org
> Subject: Re: Upgrading Sarge to Etch - failing to boot new kernel
> >>> Another option: Could you try "linux-image-2.6-alpha-legacy" instead
> >>> of -generic? This uses another start address that may be needed for
> >>> some machines and MILO. But as you have read from my prev message
> >>> below, I don't think any kernel after 2.6.22 would work. As you are
> >>> trying .18, you should have luck, but don’t upgrade to etchnhalf!
> >>>
> >>
> >> Okay, haven't expected to find a kernel on the 3rd DVD. I will try it
> >> after the weekend and report whether it works.
> >
> > Good news, it worked. So now I'm running Etch with the 2.6.18 legacy
> > kernel. For now it's only the base system without X, using the english
> > locale, but other packages shouldn't interfere with MILO. The Lenny
> > DVD contains a 2.6.26 legacy kernel image - I feel I will succumb to
> > the temptation to install it - at worst it will cost me one hour of
> > reinstalling Etch-through-Sarge.
> > Best and thanks for help,
> >
> So, the upgrade to Lenny went without problems. It also installed
> automatically the 2.6.26. The problem with 2.6.26 is, it panics because it can't
> find my SCSI drive (the 2.6.18 still boots fine). It will print the message to add
> the correct 'root' parameter, then the available partitions message, after
> which it doesn't print any. I assume something has changed in the order
> things are initialized? I found this:
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=323885
> Tried mv /etc/rcS.d/S40hotplug /etc/rcS.d/S25hotplug but it didn't work
> (neither proceeds further nor prints any available partitions). I also know,
> that IDE drives where moved from hda... to sda..., so I expect to find what
> previously was /dev/sdb7 at /dev/sdf7, but setting this as root does not help.
> Any clue what should be done now?
> Best,
> --
> piotrek
> --
> To UNSUBSCRIBE, email to debian-alpha-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: [🔎] 4C1FC594.5040501@gmail.com">http://lists.debian.org/[🔎] 4C1FC594.5040501@gmail.com

Reply to: