[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Upgrading Sarge to Etch - failing to boot new kernel

Another option: Could you try "linux-image-2.6-alpha-legacy" instead
of -generic? This uses another start address that may be needed for
some machines and MILO. But as you have read from my prev message
below, I don't think any kernel after 2.6.22 would work. As you are
trying .18, you should have luck, but don’t upgrade to etchnhalf!

Okay, haven't expected to find a kernel on the 3rd DVD. I will try it
after the weekend and report whether it works.

Good news, it worked. So now I'm running Etch with the 2.6.18 legacy
kernel. For now it's only the base system without X, using the english
locale, but other packages shouldn't interfere with MILO. The Lenny DVD
contains a 2.6.26 legacy kernel image - I feel I will succumb to the
temptation to install it - at worst it will cost me one hour of
reinstalling Etch-through-Sarge.
Best and thanks for help,

So, the upgrade to Lenny went without problems. It also installed automatically the 2.6.26. The problem with 2.6.26 is, it panics because it can't find my SCSI drive (the 2.6.18 still boots fine). It will print the message to add the correct 'root' parameter, then the available partitions message, after which it doesn't print any. I assume something has changed in the order things are initialized? I found this:
Tried mv /etc/rcS.d/S40hotplug /etc/rcS.d/S25hotplug but it didn't work (neither proceeds further nor prints any available partitions). I also know, that IDE drives where moved from hda... to sda..., so I expect to find what previously was /dev/sdb7 at /dev/sdf7, but setting this as root does not help.
Any clue what should be done now?


Reply to: