[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't boot a kernel under SRM



On Wed, Jan 14, 2004 at 03:36:48PM -0500, Jay Estabrook wrote:
> On Wed, Jan 14, 2004 at 12:06:05AM -0600, Steve Langasek wrote:

> > Depending on your hardware config, you may need to back down to 2.4.20
> > or 2.4.19 (I forget which) to get something bootable.  I've been told,
> > and have realized now that I can confirm, that later 2.4-series kernels
> > have trouble talking across PCI bridges on alphas.  I would hope
> > someone's working on fixing this, but I know that neither 2.4.22 nor
> > 2.4.23 can handle my ethernet/scsi card (an integrated tulip/qlogicisp
> > device, no idea if it has a proper name :).

> I believe your Tulip/QLogic combo card was called P1SE or P2SE (the latter
> if there are 2 QLogics, the former if only 1). Not ever sold separately
> by DEC, but part of bundles on various boxes, primarily to conserve on
> PCI slots used in boxes with few slots or builtins, like LX/SX.

Yep, based on the number of PCI devices registered and the number of
SCSI connectors on the card, looks like it's the P2SE.

> I've had trouble at various times with 2.4.x kernels and those cards;
> when last I checked (2.4.21, IIRC), they were OK, but could be broken
> now. I believe 2.6.x is OK WRT those puppies, but I may not have
> checked for a while...

> Just checked: 2.6.1 GENERIC UP on LX164 with P1SE worked just fine,
> SCSI and NIC...

Ok.  Definitely looks broken with 2.4.22 and 2.4.23; if 2.6.1 works,
maybe I'll have to pester some people for 2.6 support in d-i...

Cheers,
-- 
Steve Langasek
postmodern programmer

Attachment: pgpbZdeAyLpS3.pgp
Description: PGP signature


Reply to: