[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't boot a kernel under SRM



On Wed, Jan 14, 2004 at 09:10:52PM +0100, Jan-Benedict Glaw wrote:
> On Wed, 2004-01-14 11:06:01 -0600, Steve Langasek <vorlon@netexpress.net>
> wrote in message <[🔎] 20040114170601.GB14903@tennyson.netexpress.net>:
> > > Keep in mind that there are two drivers for "tulip" style network chips.
> > > "tulip" is for the newer cards, "de4x5" is for older cards.
> > > Unfortunately, there are some PCI IDs which are accepted by both
> > > drivers, but only one of them will properly drive the hardware.
> > 
> > Well, unless the coverage of the tulip driver has *changed* since
> > 2.4.19, mine definitely uses the tulip module.

> But to be save, please try the other driver once.

Tried it -- doesn't work any better. :)

Curiously, I threw a 3c905 card in the box, and can't get it to work
from the debian-installer, either; gives me a "too much work for
interrupt" error, even if I force it into 10baseT mode.  Will have to
play some more with this...

> > > >From my Miata (PWS 500) I also remember having had some trouble with
> > > the qlogic driver, but those vanished at some time. However, I don't
> > > remember *what* actually solved that...

> > I'm pretty sure, based on what I've heard from others working with
> > 2.4.2x, that there are still outstanding problems with PCI bridges on
> > alphas as of 2.4.23.

> There have been patches around for 2.6.x IIRC. I don't know for sure if
> they've been integrated to now...

If you can give me a pointer to a patch for 2.4 (or one that could
easily be backported), I'd be happy to look at integrating this for
sarge.

Thanks,
-- 
Steve Langasek
postmodern programmer

Attachment: pgpOZxq0lWv_A.pgp
Description: PGP signature


Reply to: