[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Enlightenment makes the mouse freeze intermittently

Peter Petrakis wrote:

Hi ,

So, the one problem I'm having is that if I run enlightenment, the mouse
stops working for a couple of seconds at a time, then works for a couple
of seconds, on and off.  With sawfish, I see this one-or-two second
delay only once every few minutes, and don't see it at all with no WM
running -- then again, haven't spent enough time sans WM to know whether
that has the every-few-minutes problem like sawfish.

Do you have the GPM daemon running while X is running?
If so, try disabling that before starting X. Call me crazy but this sounds
like some sort of interrupt problem.

D'oh! Silly me. That should have been the first thing I tried. Turned gpm off, now it works beautifully. I suppose I could also use /dev/gpmdata...

What kernel are you running
and what out of the ordinary options do you have enabled?

Debian's 2.2.19 nautilus binary image.  Nothing special otherwise.

Oh- enlightenment also segfaults a lot, but haven't looked into this yet
with gdb/strace.  And it's unlikely to be supported, since they're
focusing on E17...

I wrote a small fix for E 16.5 for a segfault or fpe , I dont remember
which. I'll dig it up and send it to you and the list.

Cool! It segfaults for me every time it starts, but clicking "Restart Enlightenment" makes it work pretty well. I'll try your patch when you send it to the list, and if that fails then I'll investigate further.

There's also
an outstanding bug against E's background managment that I found (didnt
and yet to fix). Doesn't read files that have spaces in the name  :-)


Jay, I do have an IDE CDROM, but now that it works without gpm running, I'm not sure that was the problem...


-Adam P.

GPG fingerprint: D54D 1AEE B11C CE9B A02B  C5DD 526F 01E8 564E E4B6

Welcome to the best software in the world today cafe! <http://lyre.mit.edu/%7Epowell/The_Best_Stuff_In_The_World_Today_Cafe.ogg>

Reply to: