[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Enlightenment makes the mouse freeze intermittently


I just started using X on my group's Nautilus, and (almost) everything works great! Galeon/mozilla, gnumeric, evolution... I am so impressed that so much works so well under alpha -- but then, most stuff also works well on my pmac at home, and a Netwinder I use (ARM). Haven't tried making the Voodoo 3 DRM work yet, will have to upgrade to a 2.4 kernel first... Hooray for cross-platform free software, and Debian in particular!

So, the one problem I'm having is that if I run enlightenment, the mouse stops working for a couple of seconds at a time, then works for a couple of seconds, on and off. With sawfish, I see this one-or-two second delay only once every few minutes, and don't see it at all with no WM running -- then again, haven't spent enough time sans WM to know whether that has the every-few-minutes problem like sawfish.

Oh- enlightenment also segfaults a lot, but haven't looked into this yet with gdb/strace. And it's unlikely to be supported, since they're focusing on E17...

This is a UP1000 with Voodoo3 and debconf-managed XF86Config-4 and Xwrapper-config, X nice-value set to -10.

Any ideas?

-Adam P.

GPG fingerprint: D54D 1AEE B11C CE9B A02B  C5DD 526F 01E8 564E E4B6

Welcome to the best software in the world today cafe! <http://lyre.mit.edu/%7Epowell/The_Best_Stuff_In_The_World_Today_Cafe.ogg>

Reply to: