[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sshd no longer accepts connections

On Tue, Feb 13, 2001 at 09:41:27AM +0100, Paul Slootman wrote:
> On Mon 12 Feb 2001, Jon Leonard wrote:
> > 
> > I worked around it by recompiling it:
> > apt-get --compile source man-db, and then doing a dpkg -i on the resulting
> > .deb file.  I had to do a hold in dselect as well, because otherwise it
> > wants to re-"upgrade" the package.
> > 
> > Gvim is similarly misbuilt...
> > 
> > I don't know the right way to ask for a rebuild of a package.
> Asking here is basically a good way :-)
> I wonder whether that's the right way to go, however; on my system
> (updated to unstable almost every day), I've never seen this problem
> with man.  This makes me wonder if perhaps you have some outdated libs
> or whatever that causes this, and by recompiling against those outdated
> libs the problem would probably go away (as apparently it did in your
> case).
> And as for gvim, what do you mean exactly when you say "similarly
> misbuilt"?  Also gives errors when typing "man pam" ? :-)  I haven't
> tried gvim (I try to stay away from the mouse as much as possible),
> but vim is just fine.

Ok, I'll be more verbose.  (And I don't like mice either, but my wife likes
having gvim available, so...) 

There are 3 packages that are currently giving me trouble:
w3m, man-db, and vim-gtk.

The problem with w3m is that it wants a newer version of libc than I have:

dselect - recursive package listing                  mark:+/=/- verbose:v help:?
EIOM Pri Section  Package      Description
 *** Opt text     w3m          WWW browsable pager with excellent tables/frames 
 *** Req base     libc6.1      GNU C Library: Shared libraries and Timezone data
w3m          installed ;  install (was: install).  Optional                     
w3m depends on libc6.1 (>= 2.1.97)
w3m suggests w3m-ssl (>= 0.1.10+0.1.11pre+kokb23-1)

frost->jleonard% dpkg -l libc6.1
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name           Version        Description
ii  libc6.1        2.1.3-15       GNU C Library: Shared libraries and Timezone

Telling dselect to hold w3m gets me past that, which lets me install the
current versions of all the packages (as seen by dselect with my sources.list).

The problem with man is looks like this:

frost->jleonard% man vi
Reformatting vi(1), please wait...
[blank screen in the pager]
sh: ../debian/tmp/usr/bin/zsoelim: No such file or directory
 Manual page vi(1) line ?/? (END)

It only generates the zsoelim message once for each man page looked at, though
installing a man-db package resets that.  My best guess would be that man-db
was compiled on a system with zsoelim in an unusual place, and the binary is
remembering that path.

For vim:

frost->jleonard% rehash
frost->jleonard% which gvim
gvim: Command not found.

This is suprising, because I have vim-gtk installed.

After I install the version I got from "apt-get --compile source man-db", man

frost:/usr/src/packages/man-db# dpkg -i man-db_2.3.16-1.1_alpha.deb 
(Reading database ... 48788 files and directories currently installed.)
Preparing to replace man-db 2.3.16-1.1 (using man-db_2.3.16-1.1_alpha.deb) ...
  Removing catpages as well as /var/cache/man hierarchy.
Unpacking replacement man-db ...
Setting up man-db (2.3.16-1.1) ...
  Building manual page index in background.

After the (long compile) vim rebuild/install, then gvim works:
frost:/usr/src/packages/vim# apt-get --compile source vim
frost:/usr/src/packages/vim# dpkg -i vim-gtk_5.6.070-1_alpha.deb 

I suspect that the vim-gtk was built on a system that didn't have gtk
installed at the time, so the configure step built a non-graphical vim.

Doing install in dselect re-breaks man & gvim.

My sources.list may be (part of) the problem.  It contains:

deb http://http.us.debian.org/debian stable main contrib non-free
deb-src http://http.us.debian.org/debian stable main contrib non-free
deb http://non-us.debian.org/ stable/non-US contrib main non-free
deb-src http://non-us.debian.org/ stable/non-US contrib main non-free
deb http://security.debian.org/ potato/updates main contrib non-free
deb-src http://security.debian.org/ potato/updates main contrib non-free
deb http://http.us.debian.org/debian dists/proposed-updates/
deb-src http://http.us.debian.org/debian dists/proposed-updates/

Would any more information help to diagnose the problem?

My system is a 21164A, if that's any help...

frost->jleonard% cat /proc/cpuinfo 
cpu                     : Alpha
cpu model               : EV56
cpu variation           : 0
cpu revision            : 0
cpu serial number       : Linux_is_Great!
system type             : EB164
system variation        : LX164
system revision         : 0
system serial number    : MILO-2.0.35-c5.
cycle frequency [Hz]    : 599828904 
timer frequency [Hz]    : 1024.00
page size [bytes]       : 8192
phys. address bits      : 40
max. addr. space #      : 127
BogoMIPS                : 593.49
kernel unaligned acc    : 0 (pc=0,va=0)
user unaligned acc      : 39158409 (pc=12004e170,va=1203801d2)
platform string         : N/A
cpus detected           : 0


Jon Leonard

Reply to: