[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Initial Installation.

On Tue 20 Jan 1998, Christopher C Chimelis wrote:
> Thanks for the info/additions...I haven't heard from the nano-HOWTO author
> recently, so I'll drop an email with some revisions to him later on.  If I
> don't hear back, I'll take over the nano-HOWTO and update it myself.

My boss kindly bought me an Alpha XL300 last friday, so I've been
spending the weekend playing around with it.  Here's a first report on
my experiences with it. Feel free to skip it :-) Maybe just read the
last couple of paragraphs...

I already had an UDB, on which I've installed RH 4.0. That was over a
year ago. I remembered that that was pretty confusing, especially the
MILO / boot / root floppy thing. It still is. The worst thing with RH
was that the needed images weren't included on the installation cdrom
(or at least I couldn't find it); I had to go to gatekeeper to get MILO,
for instance.

Anyway, I tried RH 4.0 on my XL. After discovering that my machine is an
"xlt" and not a plain "xl" it went reasonably ok. I was still confused
with having to boot with the MILO floppy and after that inserting the
"boot" floppy; something needs to be done about the naming there.

I'd partitioned the disk (a Quantum 1080) with the BIOS setup thing.
That created 6MB and 1000MB+ FAT partitions. Unfortunately, the RH fdisk
/ kernel combo didn't pay attention to the geometry in the partition
table, so I got no end of "logical / physical endings not same"-type
messages. After using the extended menu and choosing 64 heads, 63
sectors (I think) and the corresponding amount of cylinders that was

The wierd thing is that the CMOS setup had put the 6MB partition as
single logical partition (5) in an extended partition (2). That left the
1GB partition in (1). I didn't want to touch the 6MB partition, as I'd
defined that to be the place for MILO. That left me with 3 primary
partitions to play with...

Anyway, I had to copy MILO by hand onto the disk (RH's setup didn't do
that). In the end it worked ok (as well as RH 4.0 does, anyway :-).

I then went to install Debian. Is it really necessary to create all
those floppies? That's irritating if the stuff is available via

I had some trouble while selecting the swap partition. As I already had
the swap partition from the RH install, I wanted to skip the
initialisation of the swap partition. That's not a good idea... The
procedure gets all confused and keeps putting the initialisation as next
step. Furthermore, something went wrong with "configuring modules", I'm
not sure what. I'll try to keep a closer watch next time.

Finally, I tried to install / upgrade the packages. I'd configured my
i386 box as a masquerading host to the internet. Pointing dselect at a
mirror didn't work; it couldn't find ANY package files, and after that
it refused to try again (I'd downloaded some on my i386 by hand, and
mounted that via NFS). At one point dselect started to barf on "empty
filehandle at <P>:34" or something like that.  It still does...

I then installed a number of packages by hand. BTW, 'dpkg -i
base/ldso_1.7.14-2.deb' is a BAD idea... It removed /sbin/ldconfig, and
as it's a dummy package, it doesn't install a new one :-(  Why doesn't
this package simply contain the ldconfig that's on the base floppies?

The dependencies on libc6 is confusing (as already noted by someone else
on this list). As different revisions of libc6 are supposed to be
compatible, why not make the stuff dependent on libc6 and let libc6.1
provide libc6?

OK, for those still with me, this has just been a venting of ideas and
impressions of my first encounter with Debian/Alpha.  I'll reinstall
next weekend, and will try to make more notes of what I did, what went
wrong, and how things can be improved.  Any suggestions before I do

Paul Slootman
home: paul@wurtel.demon.nl | work: paul@murphy.nl
http://www.wurtel.demon.nl | Murphy Software, Enschede, the Netherlands

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-alpha-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: