[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: "BUG: soft lockup" on A1200; was: Re: Updated installation images for Debian Ports 2019-04-20

CC linux-ide, as people there may be more familiar with the quirks and
caveats of SD2IDE adapters

On Tue, Dec 10, 2019 at 3:56 PM Karoly Balogh (Charlie/SGR)
<charlie@scenergy.dfmk.hu> wrote:
> On Mon, 9 Dec 2019, Karoly Balogh (Charlie/SGR) wrote:
> > > It would be interesting to know if other people with A1200s have
> > > issues with IDE or not....
> >
> > Sorry for bumping this thread after a few months, I just wanted to
> > report that I recently built a mainline 4.19.87 kernel with GCC 7.4.0,
> > (playing with some Buildroot thing) and I think I ran into exactly this
> > issue on my A1200.
> > (...)
> > If that's extra info, the same kernel works flawlessly in FS-UAE (with an
> > emulated A1200 IDE controller), so the problems only occur on real
> > hardware.
> OK, so I did some more tests:
> 1., I tried the PATA Gayle driver. This one fails to boot in UAE, seems to
> be able to probe the units, then unable to read blocks from them it seems.
> At least in FS UAE on my Mac. I could try to fetch a proper crashlog
> somehow... Note that the IDE Gayle driver works fine with the same
> emulator setup.
> 2., The PATA Gayle driver also locks up on my Amiga 1200 similar to the
> IDE Gayle driver.
> 3., Actually, it still might be a problem with the SD2IDE adapter. With
> the PATA Gayle driver, it doesn't even enumerate the master unit, just
> locks up. With the IDE Gayle driver, it shows the device on the bus, then
> locks up. When the lockup occurs, with the PATA Gayle driver, the HDD LED
> remains lit. With the IDE Gayle driver, it remains dark, but:
> If I try to boot the kernel from an actual 2,5" HDD (Samsung 40GB,
> relatively recent), none of the enumeration problems seem to be happening,
> and both the IDE driver and the PATA driver shows the partitions on the
> HDD properly, then waits to the root volume to appear. Sadly this HDD
> doesn't have a Linux root partition tho, and no disk space to make one. :(
> So can't boot further to test the system.
> For now, I ordered an SD2IDE adapter with another chipset, and I'll try to
> get a real hard disk, or any other device (maybe an IDE DoM or something)
> to test with. (But again, the problematic SD2IDE works with AmigaOS just
> fine, and also worked with NetBSD 7.1 at least, and as I have two of the
> same SD2IDE adapters, I tried with both, but both show the same symptoms.
> Also tried SD cards from multiple makers, made no difference, so it must
> be that SD2IDE model somehow.)
> Cheers,
> --
> Charlie
> (Ps: are these tests/sharing this kind of info is useful? I stop spamming
> if no one is really interested.)

Reply to: