[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: FW: Call for m68k/atari debian-installer testers

On Mon, 2004-05-10 at 15:24, Stephen R Marenka wrote:
> On Mon, May 10, 2004 at 10:59:53AM +0200, Kars de Jong wrote:
> > On Mon, 2004-05-10 at 10:25, Szymanski, Frank-Peter (DMT) wrote:
> > This is caused by a missing boot parameter: ramdisk_size=20000
> > The default maximum ramdisk size is 4 MB, the d-i ramdisk is quite a bit
> > bigger.
> Sorry if I didn't document that clearly enough. This is required to
> support 2.2 kernels, although I think I can cut that in half soon.
> > I tried the Atari version of the image on my HP300 this weekend (I have
> > a working framebuffer now, yay!) which worked fine when I also passed
> > the option "debian-installer/framebuffer=false". Without that parameter,
> > I just got a black screen.
> Which kernel? 

My own, that would be 2.4.26 as of yesterday. I suppose something is
still broken in the framebuffer code.

> Whoa, hp300? I didn't know that subarch ever had a fully supported
> kernel. Is it worth adding full debian/d-i support?

It doesn't have a fully supported kernel yet.
I've written a TFTP boot loader for it, and added "normal" m68k bootinfo
support, so I'm getting pretty close.

What does debian/d-i support mean? A partioner? Since I don't have a
driver for the SCSI controller yet, that's not going to make much sense

I also haven't decided on the partition table style yet. I don't really
like BSD disklabels.

> > The installer seems to work. However, I don't have a disk driver yet, so
> > the partioner failed. My network was configured OK though, so I thought
> > I should be able to use an NFS root instead, but that seems to be
> > impossible. How are you supposed to start an NFS root these days? The
> > installation manual of Sarge still talks about unpacking root.tar, but
> > that no longer exists.
> If you can walk me through what you need for nfs root, I'll build it
> if I can.

I have no idea... the installation manuals for testing and unstable both
mention untarring the root archive named root.tar.gz for this, but I
can't find this archive anywhere.

Other systems which support net booting like sparc or mips don't seem to
have it either, so I guess this is some leftover from the past.

Normally an NFS root is just a freshly installed base system, not
flavour-specific. What I expected to be able to do was to mount my NFS
filesystem from the installer and then use that as the installation
target instead of a disk partition. But the installer really seems to
dislike not having any disks...



Reply to: