[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: FW: Call for m68k/atari debian-installer testers

On Mon, 2004-05-10 at 10:25, Szymanski, Frank-Peter (DMT) wrote:
> > How much RAM can you fit in a Sun-3? Debian-Installer needs 
> > quite some RAM
> > > these days...
> > 
> > We've had a successful test at 24MB. I'm rather hoping some changes I
> > have planned will drop that to 16MB, without changing the form of d-i.
> > After that, we'll have to get a bit more radical. I'd like to see how
> > low we can go, but don't plan on any of that for sarge.
> On ATARI RAM is also an issue.
> so this weekend I tested the debian installer on my three falcons with
> the following setup:
> Falcon with CT060 (full MC68060 card by Rodolphe Czuba), 512 mb FastRAM,
> 14 mb ST-RAM, Videl (640x480x256)
> Falcon with Afterburner (full MC68040), 64 mb FastRAM, 4 mb ST-RAM, NOVA
> (1024x768x256)
> stock Falcon (MC68030/68882), 14 mb ST-RAM, Videl (640x480x256)
> Although I am using MiNT/N.AES mainly I tested every machine with TOS
> 4.04.
> These are the results:

> Falcon/CT060 and Falcon030: 
> attempt to access beyond end of device
> 01:00: rw:0, want 7511, limit=4096
> Ext2-fs error (device ramdisk (1,0))
> ext2_read_inode: unable to read inode
> block-inode = 987, block 7510
> kernel panic: No init found. Try passing init = option to kernel

This is caused by a missing boot parameter: ramdisk_size=20000
The default maximum ramdisk size is 4 MB, the d-i ramdisk is quite a bit

I tried the Atari version of the image on my HP300 this weekend (I have
a working framebuffer now, yay!) which worked fine when I also passed
the option "debian-installer/framebuffer=false". Without that parameter,
I just got a black screen.

The installer seems to work. However, I don't have a disk driver yet, so
the partioner failed. My network was configured OK though, so I thought
I should be able to use an NFS root instead, but that seems to be
impossible. How are you supposed to start an NFS root these days? The
installation manual of Sarge still talks about unpacking root.tar, but
that no longer exists.

Kind regards,


Reply to: