[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Getting the Nouveau driver in Lenny and a half

On Fre, 2009-03-20 at 17:19 +0100, Henry-Nicolas Tourneur wrote:
> > 
> > There are other potential options, e.g.
> > 
> >       * Backport EXA changes required by nouveau to the lenny
> >         xserver-xorg-core. This might benefit other drivers as well.
> >       * Ship EXA bits required by nouveau as part of
> >         xserver-xorg-video-nouveau.
> > 
> > 
> Of course that would be great, but (correct me if I'm wrong) if we do
> that (point 1), we will change the EXA Xorg interface, therefore, we
> will have to update all X drivers and that will also make a lot of
> updates.

No, EXA has been backwards compatible since before xserver 1.1, so the
drivers should continue working without a rebuild (and also with one).

> For the second solution, I definitely don't know enough either Xorg or
> nouveau to know if that would be easy or not.

It shouldn't be too hard.

Earthling Michel Dänzer           |                http://www.vmware.com
Libre software enthusiast         |          Debian, X and DRI developer

Reply to: