[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#234535: xserver dies if I start gimp with LANG=no_NO.UTF-8

On Wed, 2004-04-28 at 12:04, Helge Hafting wrote:
> [...] the debug server froze my machine to the point where even sysrq+B 
> (instant boot) didn't work.  I tried a couple of times, using synchronous 
> mounts to limit the filesystem damage.  I managed to open an xterm and 
> type "gimp", but the machine froze before I had time to hit enter.  (The 
> suddenly nonblinking cursor still sat at the end of line)
> Before, I have only seen this sort of freezing when trying to use DRI
> on this particular machine.  I didn't enable DRI this time though,
> XF886Config-4 was unchanged.

The XFree86-debug server is non-modular, so the XF86Config-4 Module
section doesn't apply. As the radeon driver doesn't provide an option to
disable the DRI yet (this will be fixed in DRI CVS), the only way to
disable the DRI is probably to prevent the DRM (radeon kernel module)
from loading.

> I normally use both xfs and xfstt.  

Why? xfs has supported TrueType fonts for a while.

> Without them I had fewer fonts, but gimp ran with LANG=no_NO-UTF8.  The 
> nonascii characters were all wrong though.  Don't know if that is the 
> result of some bug, or that gimp1.2 doesn't support that locale yet?

BTW, have you tried gimp 2.0.x? It supports client side fonts via
GTK2/Pango/Xft, which will avoid server-side font issues, and be
anti-aliased as a bonus. :)

> I don't know if xfstt does something wrong, but X shouldn't really crash
> even if xfstt is wrong. One cannot trust font servers to be nice - they may be external 
> after all.

True, but if it only happens with xfstt, there might be little incentive
to fix this.

Earthling Michel Dänzer      |     Debian (powerpc), X and DRI developer
Libre software enthusiast    |   http://svcs.affero.net/rm.php?r=daenzer

Reply to: