[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#234535: xserver dies if I start gimp with LANG=no_NO.UTF-8

Branden Robinson wrote:
On Thu, Apr 22, 2004 at 02:19:01PM +0200, Michel Dänzer wrote:

On Thu, 2004-04-22 at 11:27, Helge Hafting wrote:

Branden Robinson wrote:

On Wed, Apr 21, 2004 at 01:28:00PM +0200, Helge Hafting wrote:

Branden Robinson wrote:

Core was generated by `/usr/bin/X11/X -dpi 100 -nolisten tcp'.
Program terminated with signal 6, Aborted.


Previous frame inner to this frame (corrupt stack?)

Indeed, the backtrace looks rather bogus to me.

The crash is likely related to fonts. Does it also occur with
xserver-xfree86-dbg? If yes, please try to get a backtrace with that,
and maybe try not using font servers. Otherwise, try not loading the
freetype module.

Dear bug submitter,

Can you please get back to us about this?
Sorry, I had a work deadline yesterday.

The crash is indeed related to fonts, specifically the use of xfstt.
My attempts at debugging this:
# apt-get install xserver-xfree86-dbg
Still no symbols, apparently the wrong server started although I selected the
dbg server during install.
# apt-get remove xserver-xfree86
# startx
Failure because /etc/X11/X doesn't exist
# apt-get install --reinstall xserver-xfree86-dbg
didn't help, so I removed the debug server.  This also removed
x-window-system and x-window-system-core.  Not unexpected.
# apt-get install xserver-xfree86-dbg # apt-get install x-window-system-core
This gave me a /etc/X11/X, pointing to nonexisting /usr/X11R6/bin/XFree86
Changed it to point to the existing XFree86-debug instead. (minor fault
in the dbg package?)

I could then get X up using startx, but the debug server froze my machine
to the point where even sysrq+B (instant boot) didn't work.  I tried
a couple of times, using synchronous mounts to limit the
filesystem damage.  I managed to open an xterm and type "gimp", but
the machine froze before I had time to hit enter.  (The suddenly nonblinking
cursor still sat at the end of line)

Before, I have only seen this sort of freezing when trying to use DRI
on this particular machine.  I didn't enable DRI this time though,
XF886Config-4 was unchanged.

So I gave up on the debug server, and tried commenting out
fontservers from XF86Config-4 instead. (After reinstalling
xserver-xfree86 and fixing the /etc/X11/X link.)

I normally use both xfs and xfstt.  Without them I had fewer fonts,
but gimp ran with LANG=no_NO-UTF8.  The nonascii characters were all
wrong though.  Don't know if that is the result of some bug, or
that gimp1.2 doesn't support that locale yet?

Enabling the font path for xfstt brought the crash back.  Disabling xfstt
but using xfs gave me more fonts and still no crash.  So the crash only
happens with xfstt.

I don't know if xfstt does something wrong, but X shouldn't really crash
even if xfstt is wrong. One cannot trust font servers to be nice - they may be external after all.

Please tell if there is anything else I could do to help. I have xfstt version 1.6-1
I currently run without truetype fonts as I want to try UTF-8 more.
My xfstt is available at host hh.aitel.hist.no port 7101 if you want to
test directly for unusual responses.

Helge Hafting

Reply to: