[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems with DRI and i815



Hi all,

My employer has just bought me a a HP Vectra VL400. It has an i815
integrated video chip and 256Mb of RAM.

I've installed sid on it, and have installed kernel 2.4.7 with the
i810 DRI module. X (4.1.0, from sid) is starting fine, but according
to glxinfo, DRI is not enabled.

I tried using the i810 DRI module built from the xserver-xfree86
sources, also no success.

I've also tried starting Linux with the option "mem=240M", so to leave
16Mb unused for graphics. Still no change.

Does anyone have any ideas on how to get this working? According the
DRI project documentation, the i815 should be supported with the i810
driver.

I've posted a logfile and my X config here:

http://nauseum.org/x4-i810-dri/

As far as I can tell from the logfile, the DRM is having some problems
allocating memory. I don't know enough about the DRI stuff to be able
to track down the problem though.

Any help would be appreciated.

TIA,
Rob.

-- 
Robert Norris                                          <rob@nauseum.org>
1024D/FC18E6C2        6FBF 098A A3F2 A728 490F  7743 59BD 7767 FC18 E6C2

Attachment: pgpXiKLRT7SWX.pgp
Description: PGP signature


Reply to: