[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SanDisk USB stick problem [solved]

On Wed, 9 Dec 2020 12:22:28 -0700
Fred <fred@blakemfg.com> wrote:

> When I was denied permission to write a file to the device as a
> regular user I checked the permissions and then discovered root could
> not change them.  Being a hardware oriented person I was concerned
> the SecureAccess software needed to change a write protect bit in the
> device and decided to ask for help.  I should have tried writing to
> the device as root but being very busy I didn't.  It is writable by
> root and anyone can read it so there is no problem.

I believe a mount point will always be owned by root, regardless of the
permissions of the underlying directory, because only root is allowed
to mount things. The device mounted on the mount point will normally be
owned by the logged-in user, unless /etc/fstab contains instructions to
the contrary. A device mounted while no user is logged in will be owned
by root (again, subject to fstab), something that usually happens if an
external drive has been left attached after shutting down. 

It's generally a bad idea to boot with an external medium attached,
unless it's bootable and you explicitly want to boot it. If it isn't
bootable, it will either be mounted as root (which may not prevent
other users writing to it) or the BIOS may hang.


Reply to: