[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: jessie and stretch time problem

On 10/14/18, tomas@tuxteam.de <tomas@tuxteam.de> wrote:
> On Sat, Oct 13, 2018 at 07:11:07AM +0000, Long Wind wrote:
>> Thank tomas!
>> i run "cat /etc/adjtime" in jessie and it says LOCALbut in stretch
>> /etc/adjtime doesn't seem to exist
> I see. Perhaps this is the root of the problem. On the other
> hand, perhaps, systemd is taking care of time in stretch by
> default. In that case I can't help, since my knowledge of
> systemd is minimal.

I was going to bring this up yesterday, just couldn't rope the words
in together. With debootstrap, one step the user manually does is

+++ QUOTE k/t https://www.debian.org/releases/buster/amd64/apds03.en.html +++

D.3.4.3. Setting Timezone

Setting the third line of the file /etc/adjtime to “UTC” or “LOCAL”
determines whether the system will interpret the hardware clock as
being set to UTC respective local time. The following command allows
you to set that.

# editor /etc/adjtime

Here is a sample:

0.0 0 0.0

The following command allows you to choose your timezone.

# dpkg-reconfigure tzdata

+++ END QUOTE +++

Mine currently reflects the above months after it was entered. A
similar topic came up a while back while I was using a different
debootstrap'ed copy. For that one particular instance, all those
zeroes had changed to something else that made no sense to me but
surely meant something to the computer.

I don't know how that one change occurred unless I forgot the above
step during that particular debootstrap, and then maybe the system
filled in what it thought it needed. However that change occurred, it
worked at the time because there was no notable difference in how time
was presented. ? :)

Cindy :)
Cindy-Sue Causey
Talking Rock, Pickens County, Georgia, USA

* runs with duct tape *

Reply to: