[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

What's the right way to get an unbroken mc package installed in Stretch



Stretch comes with 4.8.18, which for me is unusable due to an upstream bug fixed
in 4.8.19[1], but 4.8.19 is unusable due to another upstream bug, not fixed
until 4.8.20[2]. I configured stretch-backports in sources.list, but apparently
it has no newer mc version available. 4.8.21 is on the mirrors, so I downloaded
it from a mirror and installed it with dpkg. It works fine, but now apt is
broken because it thinks mc is broken and needs to be removed by "apt
--fix-broken install". Apparently apt thinks mc depends on different packages
than dpkg does:

# apt install inxi
...
The following packages have unmet dependencies:
 inxi : Depends: gawk but it is not going to be installed
 mc : Depends: libext2fs2 (>= 1.37)
      Depends: libgpm2 (>= 1.20.7) but 1.20.4-6.2+b1 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install'

# dpkg-reconfigure mc
/usr/sbin/dpkg-reconfigure: mc is broken or not fully installed

Am I the only one who needs mc to work in Stretch? What do others do?

[1] fubar right pane at startup with saved long file listing
http://midnight-commander.org/ticket/3758

[2] VFS: timestamps not being preserved due to uninitialized struct stat
st_[acm]tim.tv_nsec (#3821)
http://midnight-commander.org/ticket/3821
-- 
"Wisdom is supreme; therefore get wisdom. Whatever else you
get, get wisdom." Proverbs 4:7 (New Living Translation)

 Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata  ***  http://fm.no-ip.com/


Reply to: