[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Error while upgrading from Wheezy to Stretch

On Thu 12 Apr 2018 at 06:42:33 (-0400), Dan Ritter wrote:
> On Wed, Apr 11, 2018 at 07:57:07PM -0500, David Wright wrote:
> > On Wed 11 Apr 2018 at 15:31:32 (-0400), David Parker wrote:
> > > I am trying to upgrade two test boxes from Wheezy to Stretch (skipping
> > > Jessie).  The upgrade worked on one of them, although I ran into errors and
> > > had to run "apt-get -f install" a few times, but that resolved the issues
> > > and it ultimately worked.
> > > 
> > > However, on the second box, I ran into an error about halfway through the
> > > upgrade, and I'm not able to get past it.  No matter what I do, I keep
> > > running into version mismatch issue with libpam-modules.  It's preventing
> > > the upgrade from finishing.
> > 
> > The other "incantation" that's worth trying is
> > 
> > # dpkg --configure -a

That's the short answer.

> I would start by reinstating jessie in all of your sources
> files, then try dpkg --configure -a, then apt-get -f install,
> then apt-get dist-upgrade to jessie. After a successful jessie
> reboot, upgrade to stretch.

dpkg --configure -a   and   apt-get -f install   can be useful
to fix a logjam, but when you get an error like
 E: Sub-process /usr/bin/dpkg returned an error code (1)
it's worth running dpkg directly, seeing which packages are stuck,
and then try   dpkg -i <all the affected package .deb filenames>
as this can sometimes fix circular and reciprocal dependencies
that running from apt* is unable to solve.

BTW if they're test boxes, keep on trying: you may learn something
useful about rescuing systems, which the reinstall people won't.


Reply to: