[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Error while upgrading from Wheezy to Stretch


I am trying to upgrade two test boxes from Wheezy to Stretch (skipping Jessie).  The upgrade worked on one of them, although I ran into errors and had to run "apt-get -f install" a few times, but that resolved the issues and it ultimately worked.

However, on the second box, I ran into an error about halfway through the upgrade, and I'm not able to get past it.  No matter what I do, I keep running into version mismatch issue with libpam-modules.  It's preventing the upgrade from finishing.

# apt-get -f install
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libcfg4 libcib1 libclass-isa-perl libconfdb4 libcoroipcc4 libcoroipcs4 libcrmcluster1 libcrmcommon2 libevs4 liblogsys4 libpe-status3 libpengine3 libpload4 libquorum4 libsam4 libstonithd1 libswitch-perl
  libsystemd-login0 libtransitioner1 libvotequorum4
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 199 not upgraded.
2 not fully installed or removed.
Need to get 0 B/308 kB of archives.
After this operation, 62.5 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Preconfiguring packages ...
dpkg: dependency problems prevent processing triggers for man-db:
 man-db depends on bsdmainutils; however:
  Package bsdmainutils is not configured yet.

dpkg: error processing archive /var/cache/apt/archives/libpam-modules_1.1.8-3.6_amd64.deb (--unpack):
 dependency problems - leaving triggers unprocessed
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any ideas or suggestions for resolving this will be greatly appreciated.


Dave Parker '11
Database & Systems Administrator
Utica College
Integrated Information Technology Services
(315) 792-3229
Registered Linux User #408177

Reply to: