[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Error while upgrading from Wheezy to Stretch

On Wed, Apr 11, 2018 at 07:57:07PM -0500, David Wright wrote:
> On Wed 11 Apr 2018 at 15:31:32 (-0400), David Parker wrote:
> > I am trying to upgrade two test boxes from Wheezy to Stretch (skipping
> > Jessie).  The upgrade worked on one of them, although I ran into errors and
> > had to run "apt-get -f install" a few times, but that resolved the issues
> > and it ultimately worked.
> > 
> > However, on the second box, I ran into an error about halfway through the
> > upgrade, and I'm not able to get past it.  No matter what I do, I keep
> > running into version mismatch issue with libpam-modules.  It's preventing
> > the upgrade from finishing.
> The other "incantation" that's worth trying is
> # dpkg --configure -a

I would start by reinstating jessie in all of your sources
files, then try dpkg --configure -a, then apt-get -f install,
then apt-get dist-upgrade to jessie. After a successful jessie
reboot, upgrade to stretch.


Reply to: