[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: bluetooth not working

Pierre Frenkiel wrote:

> this gives:
>     --> pactl list short
>     0       module-alsa-sink        device=default
>     1       module-alsa-source      device=default
>     2       module-native-protocol-unix
>     0       alsa_output.default     module-alsa-sink.c      s16le 2ch
>     44100Hz       IDLE
>     0       alsa_output.default.monitor     module-alsa-sink.c      s16le
>     2ch 44100Hz       IDLE
>     1       alsa_input.default      module-alsa-source.c    s16le 2ch
>     44100Hz       IDLE
>     0       protocol-native.c       pactl
> but I have before to check whether pulseaudio is still alive, as it exits
> very often, as if there was a timeout, which is not the case.

if it exits, it might be crashing. 

I don't see in the output above some other device except your pc

25      module-bluez5-device    path=/org/bluez/hci0/dev_40_98_4E_90_56_E3

3       alsa_output.pci-0000_00_1b.0.analog-stereo.monitor     
module-alsa-card.c      s16le 2ch 44100Hz       SUSPENDED
4       alsa_input.pci-0000_00_1b.0.analog-stereo       module-alsa-card.c     
s16le 2ch 44100Hz       RUNNING

5       bluez_source.40_98_4E_90_56_E3.a2dp_source     
module-bluez5-device.c  s16le 2ch 44100Hz       RUNNING

Where I usually have to manually do

pactl load-module module-loopback

>>> I also tried "pactl load-module module-bluetooth-discover" with the
>>> following result
>>>     Connection failure: Connection refused
>>>     pa_context_connect() failed: Connection refused
>> Are you trying to do this from root?
>    no, but same remark as above for pulseaudio.

If it crashes I noted that restarting PA does not repair everything, but I
have to logout and login (it starts in user session). Either find out what
needs to be done after restarting PA, to fully recover or logout and login.

In any case crashing PA is not normal. I found out for debugging you could
kill PA and start it from the command line, but better disable autostart
and logout/login and start manually from command line.

echo "autospawn = no" > ~/.pulse/client.conf

>    it gives:
>    -->pactl load-module module-bluetooth-discover
>    3
> I tried again bluetoothctl:
>     bluetooth]# scan on
>     Discovery started
>     [CHG] Controller 3C:95:09:46:D6:74 Discovering: yes
>     [CHG] Device B0:34:95:41:6A:43 RSSI: -89
>     [CHG] Device 57:88:14:78:8A:48 RSSI: -43
>     [bluetooth]# devices
>     Device B0:34:95:41:6A:43 B0-34-95-41-6A-43
>     Device 57:88:14:78:8A:48 SLBB  4 A1
>     [bluetooth]# connect 57:88:14:78:8A:48
>     Attempting to connect to 57:88:14:78:8A:48
>     Failed to connect: org.bluez.Error.Failed

I think it never paired properly - did you try blueman?
You may need to clean up ~/.pulse directory and start over. There PA writes
information about devices already used and configured.

> As I don't need to use the speaker far from the laptop, I solved
> the problem by ordering a small wired speaker ...
> But it's a pity that this basic facility is so difficult to setup on
> Linux, and so easy on Windows( 30 seconds)

well - in Windows they don't use bluez5 yet I guess - not sure about windows
10. In linux it is work in progress and I also suffer a lot as it is not
mature enough to be used easily, but was already adopted by the most
distros and causes a lot of headache.

Here are some links if you are interested


Reply to: