[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: bluetooth not working

On Sun, 25 Mar 2018, deloptes wrote:

Have you paired and trusted the device already?

  yes, and it seemed to work.

you could list all connected devices in pulseaudio with
$ pactl list short

this gives:
   --> pactl list short
   0       module-alsa-sink        device=default
   1       module-alsa-source      device=default
   2       module-native-protocol-unix
   0       alsa_output.default     module-alsa-sink.c      s16le 2ch 44100Hz       IDLE
   0       alsa_output.default.monitor     module-alsa-sink.c      s16le 2ch 44100Hz       IDLE
   1       alsa_input.default      module-alsa-source.c    s16le 2ch 44100Hz       IDLE
   0       protocol-native.c       pactl

but I have before to check whether pulseaudio is still alive, as it exits very often, as if there was a timeout,
which is not the case.

I also tried "pactl load-module module-bluetooth-discover" with the
following result

    Connection failure: Connection refused
    pa_context_connect() failed: Connection refused

Are you trying to do this from root?

  no, but same remark as above for pulseaudio.

  it gives:
  -->pactl load-module module-bluetooth-discover

I tried again bluetoothctl:

   bluetooth]# scan on
   Discovery started
   [CHG] Controller 3C:95:09:46:D6:74 Discovering: yes
   [CHG] Device B0:34:95:41:6A:43 RSSI: -89
   [CHG] Device 57:88:14:78:8A:48 RSSI: -43

   [bluetooth]# devices
   Device B0:34:95:41:6A:43 B0-34-95-41-6A-43
   Device 57:88:14:78:8A:48 SLBB  4 A1
   [bluetooth]# connect 57:88:14:78:8A:48
   Attempting to connect to 57:88:14:78:8A:48
   Failed to connect: org.bluez.Error.Failed

As I don't need to use the speaker far from the laptop, I solved
the problem by ordering a small wired speaker ...
But it's a pity that this basic facility is so difficult to setup on Linux, and so easy on Windows( 30 seconds)

best regards,
Pierre Frenkiel

Reply to: