[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian 9 tftp issue

Thank you for that!
Now I can indeed see the files requested by my tests.

Now the funny part is that I've decided to try a VM again, and boot a netboot.xyz.kpxe file. And that worked!

However, I can still not test to get a file, even with the tftp-hpa client on the machine where I'm hosting the VM.
Anyway, thank you guys very much! Maybe with time and experiments I'll figure it out :)

Catalin Soare

On Nov 22, 2017 23:15, "Ulf Volmer" <u.volmer@u-v.de> wrote:
On 22.11.2017 22:03, Catalin Soare wrote:
> However, this means that even though tftpd-hpa is running, it's not
> bound to the port 69? Or at least it's not "listening"; this seems to be
> what the netstat output is saying (there's no "listening" on the line
> with tftpd).

That's normal behavior for netstat and UDP ports. My nameserver for example:

tcp        0      0   *
   LISTEN      25         13544      3208/named
udp        0      0   *
               25         13543      3208/named

> Any ideas if I might have to do any additional configuration for
> tftpd-hpa? Or maybe use another tftpd server that has some logging that
> I could rely on?

You can add (multiple) -v switches to TFTP_OPTIONS for turning on more
verbose logging.

best regards

Reply to: