[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [SOLVED] Re: Cannot connect to WiFi

On Thu 16 Nov 2017 at 20:11:18 (+0000), Juan R. de Silva wrote:
> On Wed, 15 Nov 2017 19:48:00 +0000, Juan R. de Silva wrote:
> > Hi folks,
> > 
> > My ISP replaced my old modem with the new one. I changed my WiFi
> > Authentication key and the name of the WiFi network. Then I made Network
> > Manager to "forget" my old WiFi. Network Manager finds my new WiFi but I
> > cannot connect to it.
> > 
> > When "Authentication Key is required" dialog pops up and the key is
> > entered,j Connect button remains grayed out/disabled. Thus there is no
> > way to get through but pressing Cancel button.
> > 
> > I'm running Debian Stretch.
> > 
> > Could somebody help. It's quite urgent now.
> The problem is solved. It was Bob Weber post that led me to solution, though 
> the problem was a kind of different.
> Here what I mean. Just by looking at my password, as entered into NM, I did 
> not find any weird characters or trailing spaces in it. A typo was exclued 
> since I copy-pasted it from my password manager storage. I was in loss and 
> just for no reason, when in GNOME "Authentication required" dialog pressed 
> Backspace once... All at a sudden I get through and connected!..
> Then I copied the password I uncessfully tried to use in Network Manager and 
> pasted it bellow a password copied from my modem/router (or as David rightfully 
> called it "gateway" device).
> That was it. The original password was 64 characters and the one in my modem 
> was only 63 characters. Aparantly the modem has a limitation on the password 
> length,

The protocol sets the limits, not the router.

> which it neither shows to a user. Instead it sighlently cuts off any 
> excessive characters.
> Silly programmed device wasted 2 days of my time. Anyway I'm a happy bunny 
> now, since it solved. :-)
> Thanks folks. And the bigest credit goes to Bob.

The 64 character item is a different animal from anything with 63 or
fewer chars. A key of up to 63 ASCII printables will get encrypted
along with the SSID to produce a 64 character hexadecimal string which
is what actually gets used.

The 63 char limit is to allow a device to distinguish between the two
types of string if the unencrypted key were to contain only hexadecimal
characters, like beadedface18005551234 (the well-known tattoo parlour),
though many devices don't in fact allow direct entry of the encrypted
(64) string.


Reply to: